Jump to content


Photo

Strange speedo lights


  • Please log in to reply
No replies to this topic

#1 asalhan

asalhan

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Ford Model: Focus
  • Location:

Posted 24 November 2008 - 09:20 PM

Hey all, this is my first post in here. I did look at other posts before I posted thisone but noone else seems to have the same problem as me.

I have had my Focus 1.8 Petrol for just over a year now. The problem i have is this: when its dark you turn on the lights, your dials get illuminated. Mine get illuminated but after a short while the backlight just dies, all other things work, rev counter, speedo, indicators and various other lights. its just the backlight that doesnt work. The first time it happened, i was confused so i whacked the top of the dash and the lights flickered but didnt stay on. Sometimes i can get home from work without the lights going out but then if i have to use the car again, the backlights dont come on. Its getting dark and i cant see what speed i'm doing, apart from assuming i cant see where the needle is.

I'm going to try and take it out this week and see whether there are any loose connections behind, i hope this is the case.

If anyone has any help for me i'd be greatful.

thanks

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users