Jump to content


Help! I Bought A Titanium X By Mistake!!

  • Please log in to reply
1 reply to this topic

#1 breconblade



  • New Member
  • Pip
  • 1 posts
  • Name: dave
  • Ford Model: mondeo
  • Year: 2007
  • Location: Powys

Posted 26 May 2011 - 07:20 PM

OK, so after the roaring success of my previous Mondeo Ghia, 100000m of care free motoring, I decided to upgrade to the 2007 Titanium X. She's a beuaty, but there are a couple of bits that are making me wonder if I have bought a donkey....

i) The noise it makes when it is idling makes it sound like a 1970s Transit (no offence meant to any 1970s Transit officianados out there!)
ii) The cruise doesn't work

Yes, I know have should picked up on the engine noise when I bought it, but I couldn't see beyond the newly refurbished alloys!! Damn those alloys!!

Any advise for a new member would be greatly appreciated! Thanks

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin


    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,565 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 27 May 2011 - 11:42 AM

was the car bought from a dealer if so get back there, if the idle noise is an injector noise the injectors could need recoding this is a common fault,if its more a drumming noise it will be the aux belt and tensioner worn,the non working cruse could be several things from a fuse to the control module, without further investigation its hard to say.

Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users