• Get Your Club gear
      Get Your Club gear
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Share Your Car Experience
      Share Your Car Experience
    • Join Premium & Save
      Join Premium & Save
    • Huge Range of Ford Parts
      Huge Range of Ford Parts


DumboBattyhead

Disable Esp On 5Dr Zetec 1.6 Tdci

212 posts in this topic

Hi

Do all new Fiesta's come with the connection to disable ESP?

Specifically the 1.25 Zetec.

Thanks

Share this post


Link to post
Share on other sites
 

in my quest to have a ESP off and Parking sensor swicth I've bought the ESP off switch. I've dismantled it and traced the circuits and don't see any reason other than !Removed! mindedness on Ford's part not to have both, I have the parking sensers fitted and the ESP disable is simply a switch. This is the dismantled ESP disable switch. reverse side at the top so you can see where the circuits trace. The bit between the red squiggles on the left hand side is the LED for the system on/off on the button and the one belows is the LED for when the cars lights are on. And Yes the LED's are tiny, sub 2mm each, I'm not mioving them over thats way beyond my soldering capability. espswitch_x.jpg Pinkish (1st from left) and Black (2nd form left) is the power for the lights that come on when the cars lights are on. Blue (4th From left) is a common return from the switches and lights, and Yellow (3rd from left) is the ESP disable switch pads, and purple (Far Right) the parking sensors switch pads. The other ones appear to be the airbad warning light/ switch line but as I've not got that I can't work out the wiring. Anyway I've got the switch in parts, almost, the ESP switch slides back and forth in it's housing but the two normally blanks are stick, before I attack it wiht a hacksaw has anyone else tried to get these apart? As you look at this image below the ESP is the one on the left and I want to get the one on the right out so I can put in my parking sensor switch and then solder in the pin to the purple positions earlier.and have ESP disable and Parking sensors. The rest of the switch has common parts, same rubber pushers onto the switch contact pads boit the ESP and Parking but nothing on back of the bit where the the airbag switch suggesting it needs more bits (maybe a latching switch) which tallys in with my pad comments earlier. IMG_0063_x.JPG I can;t believe Ford have glues them in theres a little play but the one latching pin is hiding from me.

Share this post


Link to post
Share on other sites

Righty Hi.

Cold and wet and I thought I better get my finger out and put this switch in before I need it...

Looking back at the above image the parking assist has pins (from left to right) 2, 4, 7, 9 wired in so my best wiring guess.. Bold means on both switches, Red pin is present on ESP disabled switch and Blue means present on Park assist Switch

The Parking assist switch doe not have either of the resisters in though so I'm leaving well alone, I've pulled a pin from the ESP only switch and pushed it on to pin hole 3 and thats all, As far as I can tell my feeling is that the ESP LED may need differing power requirements hence the resister.

Pin 1 - Feed to the ESP Disabled Light

Pin 2 - Common return from Pin 1/ Pin 9

Pin 3 - Signal from ESP disable switch

Pin 4 - Feed to All Switches

Pin 5 - Air bag disabled light / switch (Don't have it / can't tell)

Pin 6 - Other half of 5 ie lights or switch

Pin 7 - Light to Parking Assist

Pin 8 - ???? Doesn't seem to go anywhere, can't be there for show,

Pin 9 - Signal From Parking Assist Switch

Pin 8 goes in to the blue resister at the bottom right with a circle and dot on it but go nowhere afterwards which seems really odd. It's not on my Parking assist switch and go-es nowhere near the ESP disable switch pads so I'm leaving well alone....

Anyway step 1 is done, and it's all working, I have ESP diable available and parkling sensors, As I said it looks like !Removed! mindedness on Fords part than any proper reason to sell the ESP off and Parking sensors (at least on the Zetec S model..) as options

Step 2 is getting the physical push switches apart to I can get it back in the car....Thats proving to be the hard part....

Share this post


Link to post
Share on other sites

TA DAH!!!

Sort of, the LEDS are not fitted, too fiddly!

OK I resorted to cutting apart one side of the ESP switch to get out the ESP button I wanted without damage and work out the slider mechanism. With hindsight you may be able to pry it out but it is tight and the rest of this switch was redendant anyway...

The key to all the buttongs staying (or not) is there are four half domes that act as stops in the back quarters and the "tail" in the middle at the back performs the other stop , obviously on the non existant buttons they lock in don't move, and on the moveable button they are closer together to allow sliding. Spring action is done by the rubber "contacts" bit at the front which springs out the switch and crosses the contact.

So scalpal in hand, and a bit of trepidation, I have made me a final product...

Final.jpg

For anyone wishing to try once you have a switch in bits you need to cut away on the button are roughly outlined in yellow, Yes it is fiddly, take your time and do it slowly they carve away easily and then thewhole button slides outwarads to the front.

button1.jpgbuttonblock.jpg

Fitting the "sliding" button in is just a case of pushing it from the back, but you need to gently flex the case to get it to go in. If I get time this weekend I'll write it up as a guide but it's of limited use as only people with front parking sensors will problaby want this.

As in the prior post, the LED's for car lighting and ESP on are not wired in, partly as it's too fiddly and partly as I'm still not sure what the "spare pin does"...

Once I fit it back to the car tommorow I'll post again, and at the very least it won't look lopsided like the steering wheel did without cruise control...

Share this post


Link to post
Share on other sites

Last post :)

Installed and working (albeit without the lights in/on it...)

Installed.JPG

Share this post


Link to post
Share on other sites

HI all,

I have a 1.25 Zetec on a 61 plate (Sept 2011 build date).

Without pulling the car apart for wasted time, should mine take the ESP switch?

As per Etis, the car has ''With IVD/Traction Control/ABS'' but also lists ''Less Anti-Spin Traction System''

I am looking at hopefully fitting

1514081 ESP switch + 2 "blinds" ?

However I am not attempting to remove the trim until the weather warms up (do not want to crack any trim!!)

Thanks TB

Share this post


Link to post
Share on other sites

Hi

Has anyone done this recently without problem ?

Do not want to get stuck in snow again

Ta

Share this post


Link to post
Share on other sites

Hi

Has anyone done this recently without problem ?

Do not want to get stuck in snow again

Ta

Fitted my modified switch in November but I have a 2010 car. Didn't get stuck in the snow but then I took the wimpish way out and walked into work leaving the car in the garage.

Look at it as a £35 gamble... I doubt they will have changed the car a lot unless it's a facelift model so it will probalby work. if not you may be able to sell it on on here.

Share this post


Link to post
Share on other sites

Fitted my modified switch in November but I have a 2010 car. Didn't get stuck in the snow but then I took the wimpish way out and walked into work leaving the car in the garage.

Look at it as a £35 gamble... I doubt they will have changed the car a lot unless it's a facelift model so it will probalby work. if not you may be able to sell it on on here.

Cheers mate!!

Took the plunge today, and removed centre panel. The plug was there and now hanging out of the slot with the switch ordered............ a big THANKS to you all!!

Share this post


Link to post
Share on other sites

Thanks. Done mine too.

post-55595-0-18005300-1406858650_thumb.j

post-55595-0-52682500-1406858709_thumb.j

Share this post


Link to post
Share on other sites

I got the switch today, and in it went straightaway, true 'Plug & Play' ..........

This is the hole with the card holder removed, the plug/cable assembly is fastened to the centre console behind the silver trim. There are links in this thread to further info but to get to the cable the steps are ....

  • Pull up gear surround (for access to bottom of silver trim)
  • Prise off silver trim, there are 2 metal clips at the bottom, I found a very small screwdriver an easy method to release them, then gently manupulate the centre trim to release the rest of the plastic clips
  • Prise out the connector that is located on the car main body
  • Remove the card holder
I then reassembled it all whilst awaiting the delivery of the switch

IMG_0842.jpg

Switch arrived so I connected it up, and tested it before placing it in the panel .......... just in case!!! Switch selected ESP off light 'on', ESP symbol in instrument cluster 'on' and yep you guessed it when selected again switch light off cluster light off

IMG_0843.jpg

Once all was as expected fitted the switch in its hole. All in all a top fix (well we'll see in the snow ) so thanks to people on this board and to those on the German one for all the info they posted

IMG_0845copy.jpg

Share this post


Link to post
Share on other sites

May i ask what website you got that switch? thanks

Share this post


Link to post
Share on other sites

Trust first parts.....ford dealer and great people.

I had ESP with AIRBAG light switch,£54 area all in.

Didn't want the parking sensor mod as i will never turn them off anyway and if i did i

will just turn the sound off through the menu,done mine 2 months ago,ESP plug and play job

Airbag is ford tech job £35.

Share this post


Link to post
Share on other sites

Thank you. We dont have that here in our country.

Share this post


Link to post
Share on other sites

can i ask what is the exact name of the item? having a hard time looking for it in the site.

Share this post


Link to post
Share on other sites

I got the website, the thing that i cant find is the switch itself. What is the exact name of it? thanks

Share this post


Link to post
Share on other sites

Isee the esp pad switch but its not the same as your in the picture.

Share this post


Link to post
Share on other sites

You need to ring them up as it don't show you online

mine is.1.513.292 thats the ESP switch and PASS AIRBAG ON/OFF LIGHT.

Share this post


Link to post
Share on other sites

If and its a big IF an insurance company could prove that a switch that disables what is after all a safety feature then insurance could be voided. They may be able to check on ETIS to see if an owner had added the switch.

Someone says above only "performance" add ons need to be declared. This is simply not the case. Even the fitting of a tow bar must be declared as would after market wheels or spoilers which may aid but would not add performance. An expensive HiFi is a classic example.

Share this post


Link to post
Share on other sites

+ 1 - it's sensible to notify the insurance company of any & all modifications - there is nothing worse than being uninsured should the worst happen & better to safe than very, very sorry.

Share this post


Link to post
Share on other sites

Told the AA insurance and said about the ESP switch and AIRBAG on/off and didn't want to know about the

ESP one, only the AIRBAG one,got proof for airbag one on a form saying it was added and fill in form at ford.

A lot of cars have the ESP one to turn off as standard on a switch or menu but not the airbag on/off.

And the pass airbag switch is a key so when off its off,esp comes back on when you start car again.

Still ring them as i did but no charge just a letter.

Share this post


Link to post
Share on other sites

Just another thing,what goes on if you buy the car second hand like i did with things added.

You aint got a clue whats been added like i must of asked so much on here for if things was added on mine or not.

Share this post


Link to post
Share on other sites

my zetec s can turn it off but has to be done in vehicle settings which is done through the radio have you tried this ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now