Jump to content


Photo

Ford Cougar Problem


  • Please log in to reply
1 reply to this topic

#1 Jay.xy

Jay.xy

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Name: Jay
  • Ford Model: Cougar
  • Year: 1999
  • Location: Hampshire

Posted 09 June 2011 - 12:47 PM

Hi Im new to the site and wondered if anyone might be able to help.

I have a Cougar 2ltr on a 99 plate and recently it seems to be struggling to get over 3000rpm when driving. It will free rev over 3k when sat on the drive and slowly goes over that mark when driving but it seems to be laboured. I can get about 70mph but where as before it was a rapid acceleration its now slower! I havent noticed any additional stuttering or loss of power before nor have a heard any blowing. I have an induction kit fitted but no other mods.

Thanks

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 btmaldon

btmaldon

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 2,581 posts
  • Name: Bruce
  • Ford Model: BMW 320i Coupe M Sport, KA Luxury
  • Year: 2008
  • Location: Essex

Posted 10 June 2011 - 07:52 AM

When was the car last serviced?

It could be caused by a number of things, but I suggest starting with the basics:

Plugs, Leads, Fuel Filter. Is your air filter clean?

Could also be the coil pack starting to break down.

If it is idleing OK it is unlikely to be a problem with the MAF sensor, however as you have an induction kit fitted, it may have interfered with it.

What have you tried so far?


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users