Jump to content


Ford Focus Turbo Problem?

  • Please log in to reply
2 replies to this topic

#1 asifmpatel



  • New Member
  • Pip
  • 2 posts
  • Name: asif
  • Ford Model: focus
  • Year: 2004
  • Location: Lancashire

Posted 11 June 2011 - 12:23 PM

Hi there
I was looking for some advise and help with a problem i have with my car.
I have a Ford Focus 1.8 TDci Ghia 04'Reg.

i was driving yesterday, having put my foot down whilst travelling up a hill the 'turbo thrust' attempted to kick-in and

failed. Since then when i accelorate by putting my foot down fully, i can hear an annoying 'whirling' sound, when the rev's

reach about 2500. Its almost like the turbo is trying to initiate, but failing to do so.

There are no fumes being emitted from the exhaust.

Usually, when I accelalorate there is a 'lag' for about a second and then the car rapidly picks up speed in the form of a

thrust - i assume this is when the turbo kicks-in.

Ive been told its either the 'Air Mass Meter' OR the 'Turbo'.
Is there anyway i can test this or check this?
Im praying its not the turbo :-(, which im guessing will be very very costly.

I hope ive described the problem so it can be understood.
Any help would be much appreciated.

Thanks in advance and i look forward to hearing from any experts.


Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 alz


    Serial Poster

  • Budding Enthusiast
  • PipPipPipPip
  • 460 posts
  • Name: Alan
  • Ford Model: Ford Focus LX 1.8 TDCI
  • Year: 2005
  • Location: Worcestershire

Posted 11 June 2011 - 05:30 PM

I know this may sound silly to you,, but have you checked for an oil leak on the turbo oil feed, as it needs oil for the impeller to float on it bearing, if it as been starved of oil it will have failed, this is possibly why and can hear a 'whirling' (whizzing) sound

#3 Bagheera


    Feet Under The Table

  • New Member
  • PipPipPipPip
  • 125 posts
  • Name: C
  • Ford Model: Ford Focus 2 1.6 TDCI Ghia
  • Year: 2008
  • Location: Other / Non-UK

Posted 11 June 2011 - 07:25 PM

Have the turbo pipe checked, mate. Mine was replaced under warranty twice in just two regular visits.

Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users