Jump to content


Photo

Miss Firing


  • Please log in to reply
1 reply to this topic

#1 Marshall

Marshall

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: MONDEO MK 3 1.8LX

Posted 13 June 2011 - 10:17 AM

Hi all,

I have a Mondeo MK3 1.8 which was miss firing at low rev's... about 7 months ago.. I changed the coil pack, plugs and leads... and it was fine for the 7 months, but has started to miss fire again.

When I originally had this problem... it was only when I changed the leads it was cured... They weren't ford leads... I've heard the Mondeo's eat lower market HT Leads.

Has anyone else heard this and If so which make of leads would you advise??

Many Thanks

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 stef123

stef123

    Ford Enthusiast

  • Management
  • 5,749 posts
  • Name: Stef
  • Ford Model: Mondeo ST TDCI
  • Year: 2006
  • Location: Scotland
Contributor

Posted 13 June 2011 - 05:14 PM

Hi all,

I have a Mondeo MK3 1.8 which was miss firing at low rev's... about 7 months ago.. I changed the coil pack, plugs and leads... and it was fine for the 7 months, but has started to miss fire again.

When I originally had this problem... it was only when I changed the leads it was cured... They weren't ford leads... I've heard the Mondeo's eat lower market HT Leads.

Has anyone else heard this and If so which make of leads would you advise??

Many Thanks


Had very similar trouble with my focus quite a few times and again like yourself believe it to be lesser quality parts..

fitted genuine coil, plugs and leads and never a spot of bother again :)


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users