Jump to content


Photo

Focus Instrument Cluster Lights Issue


  • Please log in to reply
No replies to this topic

#1 UK Harvey ex police Focci

UK Harvey ex police Focci

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Name: harvey
  • Ford Model: Focus 1.8 TDCi LX ex-police
  • Year: 2007
  • Location: Kent

Posted 20 June 2011 - 06:55 PM

hi all and thanks for looking at my post, hopefully you can help.

I have a 2007 ford Focus estate 1.8 TDCI LX

normally i put key in ignition and then turn to the 2nd click, all instrument cluster lights come on then go off apart from the ignition coil light..... being a diesel.... then wait for the ignition coil light to go out then start the engine... during this time i can use my electric windows etc. whilst the coils are charging.....

now whats happening is:

i put key in ignition and then turn to the 2nd click, all instrument cluster lights come on then go off apart from 1) a red arrow light, located in the rev counter, the engine managment light and the ignition coil light....
during this period i cannot use my electric window....
Then when the coils are charged i start the engine and ALL lights in the instrument cluster go out as normal (none left on) and all seems good...

Any ideas as to what is going on ????

All replies greatly appreciated

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users