• Get Your Club gear
      Get Your Club gear
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Share Your Car Experience
      Share Your Car Experience
    • Join Premium & Save
      Join Premium & Save
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Sign in to follow this  
AdrianM

Bearing Squeal - No A/c

Recommended Posts

For a half minute or so after starting from cold there's a very noisy squealing sound like a bearing in distress coming from the auxilliary belt region. We just discovered that the A/C doesn't work but the squeal isn't when we try to turn it on, just when starting from cold. I'm wondering if these two things might be related. The battery isn't charging properly either (another thing that depends on the aux. belt) but that's another story

Any "usual suspects" in this area?

Share this post


Link to post
Share on other sites
 

Had similar symptoms on our SportKA which suddenly got worse. I thought it was the Aux belt tensioner as that is quite common, but turned out to be the Water Pump.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this