• Join Premium & Save
      Join Premium & Save
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Get Your Club gear
      Get Your Club gear
    • Share Your Car Experience
      Share Your Car Experience


Sign in to follow this  
Followers 0
tonyhabasa

Mondeo Mk4 Electronics Problem

1 post in this topic

I have a Mk4 bought in 2010 with 2.0 flexifuel engine. It's the model with the power button.

We were working with the car, when the electronics went crazy. We hardly could start the engine while pushing and pushing the button. First we thought the button crashed, but it's working right. When the car's on ignition and the engine does not run it makes a lot of failures - for instance tyre pressure sensor failure, IVDC failure, Transmission failure etc. It beeps and beeps creating a lot of failures. We keep pushing the button and, if we have luck, the engine starts. Then the car shows no failure. Every function works operational. The stopping of the engine is critical again. Today we cannot start the engine any more.

The Bosch system shows an unidentifiable failure, number U0167 and a communication-with-ECU failure number U040168.

So the start button is working, the accumulator is fine, the key works, but the car shows what I explained. We only have 3000kms in the car.

If anyone knows what is the problem with the car, please tell me.

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0