Jump to content


Photo

help with my zetec engine and heater


  • Please log in to reply
4 replies to this topic

#1 steplce

steplce

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: v-reg escort estate 1.6 (zetec) flight
  • Location:

Posted 14 December 2008 - 08:29 AM

my 1.6 escort estate zetec engine keeps mis-firing when ever i drive it, i replaced the plugs which helped a little but within a few weeks the mis-firing got worst.
I did run it out of petrol once and since then i've had this mis-fire but the car only does short jorneys, any advice would be great.
Also my heater blower has stopped working, i can feel the heat coming out but only very slightly as the heater blower doesn't work. i have checked the fuse.

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 ikarma70

ikarma70

    Settling In Well

  • New Member
  • PipPipPip
  • 83 posts
  • Ford Model: fiesta 1.25 lx
  • Location:

Posted 14 December 2008 - 09:42 AM

misfiring and very little from the heater.....sounds like your head gasket is going i'm afraid.
i might be wrong and i hope i am.

#3 steplce

steplce

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: v-reg escort estate 1.6 (zetec) flight
  • Location:

Posted 14 December 2008 - 09:53 AM

misfiring and very little from the heater.....sounds like your head gasket is going i'm afraid.
i might be wrong and i hope i am.

i thought that but the car doesn't over heat and theres no mayo on the oli cap.

#4 ikarma70

ikarma70

    Settling In Well

  • New Member
  • PipPipPip
  • 83 posts
  • Ford Model: fiesta 1.25 lx
  • Location:

Posted 14 December 2008 - 11:19 AM

no sludge in the coolant tank?

#5 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,560 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 14 December 2008 - 05:59 PM

when you ran out of petrol you could have sucked gunge into the fuel filter and got a partual blockage. with your heater it could be the relay,resistor pack or the switch itself.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users