Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!


Sign in to follow this  
Followers 0
toppo

mondeo 2.0ltr 115 tdci fuel comsumption low

8 posts in this topic

hi all ive got a 2005 tdci 115 mondeo with 43 thow on it,, just seviced it my self , oil filters , its got full ford service and aint due yet but i like to keep my car in good condition , ive put a KN filter on it , used magnetex oil ,

my prob is that my fuel mpg as gone down . it was doing over 40 round the town , but now only getting 30 , any one else had this prob , could it be the cold weather ? its a LX model , ive put 18 inch wheels onit , with 225 40 18 tyres , exon light kit ,

thanks mark

Share this post


Link to post
Share on other sites
 

has it gone down since the k&n was fitted? theres a good read about fuel econ here

http://www.fordmondeo.org/forum/showtopic.php?tid/775232/

no it was worse till i put the K&N in ,, its a 2005 face lift model , it says on the web sites clean the MAF out but cannot find were this is on mine ? any clues were to locate it ? its doing my head in only gettin 28 - 30 MPG slow driving ? dont realy want to get rid of it as i ove the car > but i do like good MPG cars ?

thanks for ur help cheers mark

Share this post


Link to post
Share on other sites
hi all ive got a 2005 tdci 115 mondeo with 43 thow on it,, just seviced it my self , oil filters , its got full ford service and aint due yet but i like to keep my car in good condition , ive put a KN filter on it , used magnetex oil ,

my prob is that my fuel mpg as gone down . it was doing over 40 round the town , but now only getting 30 , any one else had this prob , could it be the cold weather ? its a LX model , ive put 18 inch wheels onit , with 225 40 18 tyres , exon light kit ,

thanks mark

Do you notice any lack of power, smoke on accelerating or a whosing noise. If so check the pipes form the turbo to the inlet ( mine had a split pipe between intercooler and EGR) causing loss of MPG amongst other probs.

Share this post


Link to post
Share on other sites

on the air intake you should see a square bok with two wires onto it this contains the maf

Share this post


Link to post
Share on other sites

on the air intake you should see a square bok with two wires onto it this contains the maf
no i cannot see anything on the air intake pipe ? dont think its got one .. i have seen pics of others with one

the cars runs well , tick over ok no smoke , ive cleanthe the egr valve out today and the inlet manifold , there was abit of gunk in there ? put it back togeather en runs ok ,, still only getting 28 - 30 MPG , thow ,, wat else can i try ,

the car starts first thing , and seems to run good , had a look at the turbo pipe that normaly splits , cannot see anything wrong ? ive tryed injector cleaner , i use bp fuel and shell only / im going to change the fuel filter tomorrow as thats the only thing i aint changed ,, cannot see this improvving the fuel thow ??

thanks for ur help cheers mark

Share this post


Link to post
Share on other sites
no i cannot see anything on the air intake pipe ? dont think its got one .. i have seen pics of others with one

the cars runs well , tick over ok no smoke , ive cleanthe the egr valve out today and the inlet manifold , there was abit of gunk in there ? put it back togeather en runs ok ,, still only getting 28 - 30 MPG , thow ,, wat else can i try ,

the car starts first thing , and seems to run good , had a look at the turbo pipe that normaly splits , cannot see anything wrong ? ive tryed injector cleaner , i use bp fuel and shell only / im going to change the fuel filter tomorrow as thats the only thing i aint changed ,, cannot see this improvving the fuel thow ??

thanks for ur help cheers mark

bin on a good run to country lanes, getting over 40 mpg now so its getting better ? cleaning the egr valve must of helped ,, think short trips i use it for aint doing it no good ? and cold weather ,

Share this post


Link to post
Share on other sites
on the cold air intake filter you should see a square bok with two wires onto it this contains the maf

Thanks for the tip. Finally, an idea has been generated by this post. I was figuring this out for a week now.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0