Jump to content


Photo

mondeo 2.0ltr 115 tdci fuel comsumption low


  • Please log in to reply
7 replies to this topic

#1 toppo

toppo

    Newbie

  • New Member
  • Pip
  • 8 posts
  • Ford Model: mondeo 115 tdci 2.o ltr
  • Location:

Posted 14 December 2008 - 05:08 PM

hi all ive got a 2005 tdci 115 mondeo with 43 thow on it,, just seviced it my self , oil filters , its got full ford service and aint due yet but i like to keep my car in good condition , ive put a KN filter on it , used magnetex oil ,
my prob is that my fuel mpg as gone down . it was doing over 40 round the town , but now only getting 30 , any one else had this prob , could it be the cold weather ? its a LX model , ive put 18 inch wheels onit , with 225 40 18 tyres , exon light kit ,
thanks mark

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,480 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 14 December 2008 - 05:54 PM

has it gone down since the k&n was fitted? theres a good read about fuel econ here
http://www.fordmondeo.org/forum/showtopic.php?tid/775232/

#3 toppo

toppo

    Newbie

  • New Member
  • Pip
  • 8 posts
  • Ford Model: mondeo 115 tdci 2.o ltr
  • Location:

Posted 15 December 2008 - 12:11 PM

has it gone down since the k&n was fitted? theres a good read about fuel econ here
http://www.fordmondeo.org/forum/showtopic.php?tid/775232/

no it was worse till i put the K&N in ,, its a 2005 face lift model , it says on the web sites clean the MAF out but cannot find were this is on mine ? any clues were to locate it ? its doing my head in only gettin 28 - 30 MPG slow driving ? dont realy want to get rid of it as i ove the car > but i do like good MPG cars ?
thanks for ur help cheers mark

#4 mike4369

mike4369

    Mike

  • New Member
  • PipPip
  • 12 posts
  • Name: Mike
  • Ford Model: Mk4 Mondeo 2.2 TDCI TitX Sport Estate
  • Year: 2008
  • Location:

Posted 15 December 2008 - 12:47 PM

hi all ive got a 2005 tdci 115 mondeo with 43 thow on it,, just seviced it my self , oil filters , its got full ford service and aint due yet but i like to keep my car in good condition , ive put a KN filter on it , used magnetex oil ,
my prob is that my fuel mpg as gone down . it was doing over 40 round the town , but now only getting 30 , any one else had this prob , could it be the cold weather ? its a LX model , ive put 18 inch wheels onit , with 225 40 18 tyres , exon light kit ,
thanks mark

Do you notice any lack of power, smoke on accelerating or a whosing noise. If so check the pipes form the turbo to the inlet ( mine had a split pipe between intercooler and EGR) causing loss of MPG amongst other probs.

#5 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,480 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 15 December 2008 - 04:57 PM

on the air intake you should see a square bok with two wires onto it this contains the maf

#6 toppo

toppo

    Newbie

  • New Member
  • Pip
  • 8 posts
  • Ford Model: mondeo 115 tdci 2.o ltr
  • Location:

Posted 15 December 2008 - 11:29 PM

on the air intake you should see a square bok with two wires onto it this contains the maf

no i cannot see anything on the air intake pipe ? dont think its got one .. i have seen pics of others with one
the cars runs well , tick over ok no smoke , ive cleanthe the egr valve out today and the inlet manifold , there was abit of gunk in there ? put it back togeather en runs ok ,, still only getting 28 - 30 MPG , thow ,, wat else can i try ,
the car starts first thing , and seems to run good , had a look at the turbo pipe that normaly splits , cannot see anything wrong ? ive tryed injector cleaner , i use bp fuel and shell only / im going to change the fuel filter tomorrow as thats the only thing i aint changed ,, cannot see this improvving the fuel thow ??
thanks for ur help cheers mark

#7 toppo

toppo

    Newbie

  • New Member
  • Pip
  • 8 posts
  • Ford Model: mondeo 115 tdci 2.o ltr
  • Location:

Posted 19 December 2008 - 11:28 PM

no i cannot see anything on the air intake pipe ? dont think its got one .. i have seen pics of others with one
the cars runs well , tick over ok no smoke , ive cleanthe the egr valve out today and the inlet manifold , there was abit of gunk in there ? put it back togeather en runs ok ,, still only getting 28 - 30 MPG , thow ,, wat else can i try ,
the car starts first thing , and seems to run good , had a look at the turbo pipe that normaly splits , cannot see anything wrong ? ive tryed injector cleaner , i use bp fuel and shell only / im going to change the fuel filter tomorrow as thats the only thing i aint changed ,, cannot see this improvving the fuel thow ??
thanks for ur help cheers mark

bin on a good run to country lanes, getting over 40 mpg now so its getting better ? cleaning the egr valve must of helped ,, think short trips i use it for aint doing it no good ? and cold weather ,

#8 drewtiss

drewtiss

    Settling In Well

  • New Member
  • PipPipPip
  • 38 posts
  • Ford Model: Ford Focus
  • Location:

Posted 23 April 2009 - 05:08 AM

on the cold air intake filter you should see a square bok with two wires onto it this contains the maf


Thanks for the tip. Finally, an idea has been generated by this post. I was figuring this out for a week now.

Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users