Jump to content


Photo

Granda side and dash lights problem


  • Please log in to reply
3 replies to this topic

#1 John B

John B

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: Granada Scorpio Cosworth
  • Location:

Posted 14 December 2008 - 09:51 PM

:( side and dash lights not working head light OK. I have checked 15 amp fuses in main fuse box they seem OK. Any ideas of what to look at next?

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,480 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 15 December 2008 - 09:15 PM

have you checked the relay?

#3 John B

John B

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: Granada Scorpio Cosworth
  • Location:

Posted 16 December 2008 - 10:06 AM

have you checked the relay?


No I don't know which relay is just for side light and dash do you?

#4 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,480 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 16 December 2008 - 03:50 PM

the only relay i can think off is the sounder relay which is the one with the slots in, also the fuse box connections can play up which will entail removeing the top section and checking underneth for any signs of corrosion


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users