Jump to content


Display Problems With Sony 6 Cd Player

  • Please log in to reply
2 replies to this topic

#1 john58



  • New Member
  • Pip
  • 1 posts
  • Name: John
  • Ford Model: Focus 2.0 Diesel
  • Year: 2005
  • Location: Essex

Posted 17 July 2011 - 01:26 PM

I have a 2005 Ford Focus with a Sony 6 CD player. Just recently when I start the car the display doesn't come on although it plays the radio and CD okay. It's a pain because you can't see what CD is on, or what radio station is on, or the menu options. But, on very rare occasions it does come on. Has anyone had a similar problem?

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 Preee


    Ford Fruitcake

  • Moderator
  • 4,397 posts
  • Name: Paul
  • Ford Model: Focus Tit X Mk3.5 | Fiesta Zetec Mk7
  • Year: 2015
  • Location: Shropshire

Posted 17 July 2011 - 01:53 PM

Could be a loose conection , i would take it apart unplug and then plug the screen section back in or it could be a dry solder joint causing it.

#3 jeebowhite


    Resident Loon

  • Super Mod
  • 22,302 posts
  • Name: James
  • Ford Model: Sea Grey Mondeo MKIV 1.8TDCi 140ps Zetec
  • Year: 2007
  • Location: Kent

Posted 18 July 2011 - 07:21 AM

Agreed, and since the car has no warranty, you dont really have that much to lose. Call your local dealer, ask them if they have seen this before. If you are not confident doing it yourself, they may charge you less than an hour to do what could be to them, a 10 minutes job.

Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users