Jump to content


Photo

Battery Light


  • Please log in to reply
3 replies to this topic

#1 dibbles

dibbles

    Newbie

  • New Member
  • Pip
  • 7 posts
  • Ford Model: mondeo
  • Location:

Posted 25 July 2011 - 02:16 PM

This is driving me mad,I am having problems with my mondeo mk 3,I get to 2000 revs or there a bouts then the battery light flicks on and all the revs drop off and the car labours.this only happens when pulling away plus sometimes have trouble starting car.please any help or advice please

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,543 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 25 July 2011 - 03:03 PM

sounds like it could be the bushes in the alternator wearing or a battery problem, i would get the charging system checked first.

#3 dibbles

dibbles

    Newbie

  • New Member
  • Pip
  • 7 posts
  • Ford Model: mondeo
  • Location:

Posted 25 July 2011 - 03:12 PM

sounds like it could be the bushes in the alternator wearing or a battery problem, i would get the charging system checked first.

Batten has been checked and charging properly but thanks for advice

#4 johnH

johnH

    Ford Enthusiast

  • Moderator
  • 1,136 posts
  • Name: John
  • Ford Model: Focus mk2 Zetec 1.8 TDCI (Climate)
  • Year: 2006
  • Location: Tyne and Wear
Contributor

Posted 25 July 2011 - 03:56 PM

sounds to me like a connection is coming slightly loose, check the electronic cables in the engine such as earths.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users