Jump to content


Photo

2.0 Tdci - Sluggish


  • Please log in to reply
1 reply to this topic

#1 krassivy

krassivy

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Name: colin
  • Ford Model: c-max
  • Year: 2004
  • Location: Ayrshire

Posted 14 August 2011 - 11:41 AM

I have a 2004 c-max done 70k miles. LAst month it would not start and got a new fuel pump fitted. day afterI got it back it did not start again. ot taken to a different brach of same garage and they replaced a faulty sensor!

In last week car has statrted to be a bit sluggish when I change gear - at around 2000 revs power is slow to 'kick in'. Tok it to garage who have advised that clutch is slipping and needs replaced For 1200!! However, reading this website it looks like the problem could be injectors, EGR valves etc and I am wondering is it related to new fuel pump?

I dont want to spend that type of money and find it has not soled the problem. Can anyone give any advice?

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,550 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 14 August 2011 - 07:38 PM

i would remove and clean the egr, its a messy job but will only cost a few quid for some cleaner,while the valve is off check the large pipe on the bottom of the egr for splits as this would cause a power loss at around 1800 revs.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users