• Get Your Club gear
      Get Your Club gear
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Share Your Car Experience
      Share Your Car Experience
    • Join Premium & Save
      Join Premium & Save

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Sign in to follow this  
Followers 0
ryan the chef

heater

2 posts in this topic

Hi newbie here ,i have just bought a 1999 1.3 ohv fiesta and i need help please. The heater does not work, heat gets up to three of the pipes but does nor seem to go past the valve do these stick or is there a fuse for it ? Please help as i am freezing my bits off. :blink:

My Dad is quite good as a fixer/ repairer just he needs pointing in the right direction :rolleyes: ( dad here thanks son i think :unsure: )

Thanks in advance Ryan :rolleyes:

Share this post


Link to post
Share on other sites
 

its a very common fault on fiesta's,just simply disconnect the heater valve unit from its power plug,turn power on and reconnect,if the solenoid is working you should hear it clicking open and closed.

if its silent then the solenoid is duff,you can clean them up so someone posted in a previous similar thread or just simply replace the unit.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0