Jump to content


Photo

Ford Mondeo Ghia 2.0 Tdci


  • Please log in to reply
3 replies to this topic

#1 ricky2410

ricky2410

    Newbie

  • New Member
  • Pip
  • 4 posts
  • Name: ricky
  • Ford Model: mondeo ghia 2.0 tdci(53)
  • Year: 2003
  • Location: Essex

Posted 20 August 2011 - 08:26 PM

hi please help i have problems with brake lights and side lights . when the lights r turned off and i press the brake my side lights come on and all the dash lights as well when the lights r turned on the brake lights flash like a strobe light i have cheeked all the fuses and all the light connections . please help thanks ricky

ford mondeo ghia 53 plate 2.0 tdci.

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,558 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 21 August 2011 - 07:49 AM

check your brake bulbs for any broken filaments, this fault usually happens when one of the brake light filaments breaks and then touches the side light filament inside the bulb, hence when you touch your brakes it powers up the sidelights as well.

#3 ricky2410

ricky2410

    Newbie

  • New Member
  • Pip
  • 4 posts
  • Name: ricky
  • Ford Model: mondeo ghia 2.0 tdci(53)
  • Year: 2003
  • Location: Essex

Posted 21 August 2011 - 10:05 PM

hi please help i have problems with brake lights and side lights . when the lights r turned off and i press the brake my side lights come on and all the dash lights as well when the lights r turned on the brake lights flash like a strobe light i have cheeked all the fuses and all the light connections . please help thanks ricky

ford mondeo ghia 53 plate 2.0 tdci.

they are not broke when i unplug the left the problem stops and if i take the brake bolb is out then it is ok as well
and if the bolb is pluged in the earth sparks on contact please help.

#4 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,558 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 23 August 2011 - 05:12 PM

i would fit a new bulb and clean all the connectors.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users