Jump to content


Photo

Hi I'm New , I Am A New Ower Of A Mk6 1.4 Fiesta With Problems Eek!


  • Please log in to reply
3 replies to this topic

#1 enginestuff

enginestuff

    Newbie

  • New Member
  • Pip
  • 3 posts
  • Name: Adam
  • Ford Model: Granada 4x4 ghia x
  • Year: 1989
  • Location: Hertfordshire

Posted 22 August 2011 - 09:05 PM

Hello people i am Adam nice to meet you all..I'm new and i was hoping for some help.

i have Recently purchased a Mk6 1.4 zetec fiesta it was going cheap as it has had a host of issues and i thought as abit savy with cars i could fix it and have a cheap run around whilst my Granada is being rebuilt.

Firstly i was told the head gasket redone by the previous owners expense which cost over 700 pounds in total.
things that have been changed

cam belt and runners
head gasket set
HEGO sensor

was sent to ford and had the EML reset 108 quid later! wow!

i have checked the timing and its fine aswell.

BUT! there is a slight problem i have discovered , ( the reason its so cheap) it keeps on stalling.... all the time , it idles okish.. any flick of the excelerator to say move off the engine dies...

So i purchase the car for a small fee coff! coff! 400 quid coff! coff!

i pop bonnet POP!!
started the engine idling badly
and av a good look! i couldn't see anything obvious in my face but i could hear a very loud hissing almost like a air leak coming from some where , i pulled the large air box off the top of the engine it sounded alot better when removed, which reveals the edis on the right and piping going too the injector rail and too a electromagnetic switch with piping going too the throttle body and then going to something else possibly the EGR then again i couldn't see.. does this engine even have one? there is another pipe which leads from the fuel pressure regulator and i think its leading too the TB aswell but i can't actually see..

My next idea is the Throttle body. it looks like a total sod to get too even though its in my face is it a common issue for these to stop working?

So i was wondering if anyone has had this problem them selfs and it would be fantastic if for your help.

thanks!

Adam

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 enginestuff

enginestuff

    Newbie

  • New Member
  • Pip
  • 3 posts
  • Name: Adam
  • Ford Model: Granada 4x4 ghia x
  • Year: 1989
  • Location: Hertfordshire

Posted 22 August 2011 - 09:10 PM

sorry i placed this in the wrong area :blink: i have put it in the right area now SORRY!!

#3 2011fiesta

2011fiesta

    Geordie Fordie

  • New Member
  • PipPipPipPipPip
  • 1,743 posts
  • Name: Paul
  • Ford Model: 2011 Fiesta Titanium Auto
  • Year: 2011
  • Location: Tyne and Wear

Posted 23 August 2011 - 08:59 PM

Welcome to FOC Adam

#4 natz89

natz89

    Member

  • New Member
  • PipPip
  • 26 posts
  • Name: nat
  • Ford Model: fiesta
  • Year: 1999
  • Location: Somerset

Posted 24 August 2011 - 10:10 AM

Hi Adam, Im a tranee mechanic and if your in the southwest im more then happy to come and have a look for you. i have tools and equipment 2 =) it sounds to me like theres not enough air getting into the engine, if your running a petrol motor its worth having a play around with the butterfly valve, try pulling it open some more and letting her idel, also try the the HT leads, they lead from the dizzy cap and if not working right can cause mis-fires. It might be worth having the car serviced and getting a list of what needs doing then you can do it. Like i said im happy to com and have a look if your local.

let me know and goodluck =)
nat


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users