Jump to content


Photo

Idle Control Vavle Problems


  • Please log in to reply
5 replies to this topic

#1 natz89

natz89

    Member

  • New Member
  • PipPip
  • 26 posts
  • Name: nat
  • Ford Model: fiesta
  • Year: 1999
  • Location: Somerset

Posted 27 August 2011 - 12:13 PM

Hey guys n girls,
i recently brought a fiesta 1999 n everytime i drive it and put my foot on the clutch it revs really high. ive been told by a professional mechanic that its my idle control vavle and i was just wondering if this is a common problem. im only a level 2 in cars and not to sure on that. was wondering if any1 knew much about it?

Many thanks

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 btmaldon

btmaldon

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 2,587 posts
  • Name: Bruce
  • Ford Model: KA Edge, BMW 320i Coupe M Sport
  • Year: 2015
  • Location: Essex

Posted 27 August 2011 - 05:41 PM

ICV issues are common. Sometimes you can get away with cleaning them out with Carb Cleaner. Alternatively you can pick them up for about £30 on eBay. Only two or three bolts to undo and an electrical connector.

#3 natz89

natz89

    Member

  • New Member
  • PipPip
  • 26 posts
  • Name: nat
  • Ford Model: fiesta
  • Year: 1999
  • Location: Somerset

Posted 27 August 2011 - 06:11 PM

ICV issues are common. Sometimes you can get away with cleaning them out with Carb Cleaner. Alternatively you can pick them up for about 30 on eBay. Only two or three bolts to undo and an electrical connector.


Hey,
Thanks for your comment =) im going to try and clean it out. Im not sure what you would use to clean it with tho =/

#4 natz89

natz89

    Member

  • New Member
  • PipPip
  • 26 posts
  • Name: nat
  • Ford Model: fiesta
  • Year: 1999
  • Location: Somerset

Posted 29 August 2011 - 01:34 PM

So i brought some carb cleaner and it seems to have worked =)

#5 btmaldon

btmaldon

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 2,587 posts
  • Name: Bruce
  • Ford Model: KA Edge, BMW 320i Coupe M Sport
  • Year: 2015
  • Location: Essex

Posted 29 August 2011 - 05:37 PM

So i brought some carb cleaner and it seems to have worked =)

Good job. Saved yourself a few pennies.

#6 natz89

natz89

    Member

  • New Member
  • PipPip
  • 26 posts
  • Name: nat
  • Ford Model: fiesta
  • Year: 1999
  • Location: Somerset

Posted 29 August 2011 - 09:18 PM

Good job. Saved yourself a few pennies.


i certaininly have lol =) she goes all nippy now...well chuffed

Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users