Jump to content


Photo

Ecu Ford Focus Mk1


  • Please log in to reply
1 reply to this topic

#1 longy

longy

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Name: chris
  • Ford Model: focus mk1 1.8cc
  • Year: 1999
  • Location: Warwickshire

Posted 28 August 2011 - 02:26 PM

Hi all i have a ford focus mk1 1.8cc 1999.
It broke down on me the other day, i was told by green flag that it could be 2 things the coil pack or the ecu,
I have changed the coil pack but the problem still persists.
The car starts but cuts out straight away unless you keep the accelerator pedal pressed its also very loud and there is a strong smell of petrol when running, also thge engine management light comnes on.
Where can i find the ecu and will i be able to replace it with a second hand unit also will the other unit need coding to the car.

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,543 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 29 August 2011 - 08:24 AM

its unusual to require a new ecu, i would get the codes read to what the problem is, as it sounds more like a crank/cam or lambarda sensor problem


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users