Jump to content


Photo

Engine Revs Really High On Idle


  • Please log in to reply
8 replies to this topic

#1 bazz61

bazz61

    Newbie

  • New Member
  • Pip
  • 6 posts
  • Name: barry
  • Ford Model: mondeo lx
  • Year: 2006
  • Location: Lancashire

Posted 29 August 2011 - 09:00 PM

Hi can anybody help my 06 mondeo lx petrol auto has just started to play up.
Engine revs really high on idle, I've noticed a buzzing sound by the throttle,sounds electrical buzzing stops when i rev the engine. Other than that engine is running fine. Thanks

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 natz89

natz89

    Member

  • New Member
  • PipPip
  • 26 posts
  • Name: nat
  • Ford Model: fiesta
  • Year: 1999
  • Location: Somerset

Posted 29 August 2011 - 09:14 PM

Hi can anybody help my 06 mondeo lx petrol auto has just started to play up.
Engine revs really high on idle, I've noticed a buzzing sound by the throttle,sounds electrical buzzing stops when i rev the engine. Other than that engine is running fine. Thanks


Hey bazz, ive just had probs with my fiesta and revving probs and i got told it was the idle vavle. I removed it today, cleaned it with carb cleaner and it works a treat...you mite wna try it. Other to that check the sensors are all on correctly...mainly your mass air flow sensor.

goodluck
Nat

#3 bazz61

bazz61

    Newbie

  • New Member
  • Pip
  • 6 posts
  • Name: barry
  • Ford Model: mondeo lx
  • Year: 2006
  • Location: Lancashire

Posted 29 August 2011 - 09:22 PM

Cheers for that Nat i'l give it a go.

#4 natz89

natz89

    Member

  • New Member
  • PipPip
  • 26 posts
  • Name: nat
  • Ford Model: fiesta
  • Year: 1999
  • Location: Somerset

Posted 30 August 2011 - 09:59 AM

Cheers for that Nat i'l give it a go.

No worries =) let me know how it goes

#5 bazz61

bazz61

    Newbie

  • New Member
  • Pip
  • 6 posts
  • Name: barry
  • Ford Model: mondeo lx
  • Year: 2006
  • Location: Lancashire

Posted 10 September 2011 - 09:31 AM

cleaned idle valve still had the problem.friend done a diagnostic check error code p0122,Changed the throttle position sensor no change. engine still revving hard

#6 bazz61

bazz61

    Newbie

  • New Member
  • Pip
  • 6 posts
  • Name: barry
  • Ford Model: mondeo lx
  • Year: 2006
  • Location: Lancashire

Posted 10 September 2011 - 09:59 AM

No worries =) let me know how it goes

Hi nat cleaned idle valve still had the problem.friend done a diagnostic check error code p0122,Changed the throttle position sensor no change. engine still revving hard

#7 stef123

stef123

    Ford Enthusiast

  • Management
  • 5,866 posts
  • Name: Stefan
  • Ford Model: Mondeo ST TDCI
  • Year: 2006
  • Location: Scotland
Contributor

Posted 10 September 2011 - 10:03 AM

Hi nat cleaned idle valve still had the problem.friend done a diagnostic check error code p0122,Changed the throttle position sensor no change. engine still revving hard


was it just a code reader your friend used? a live data diagnostic tool would let you see what the TPS is reading when you press the pedal.

is the wiring to the sensor ok?

#8 bazz61

bazz61

    Newbie

  • New Member
  • Pip
  • 6 posts
  • Name: barry
  • Ford Model: mondeo lx
  • Year: 2006
  • Location: Lancashire

Posted 10 September 2011 - 10:13 AM

Don't know what sort of reader it was,will ask when i see him,Going out now to have a quick look at the wiring to sensor.

#9 bazz61

bazz61

    Newbie

  • New Member
  • Pip
  • 6 posts
  • Name: barry
  • Ford Model: mondeo lx
  • Year: 2006
  • Location: Lancashire

Posted 10 September 2011 - 10:18 AM

Ive noticed that the TPS makes a buzzing sound when i turn the key to ignition, then goes off when i turn the throttle then goes back on when i release the throttle, is this normal


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users