Jump to content


Photo

Electric Power Steering Pump Whine


  • Please log in to reply
1 reply to this topic

#1 Bartman

Bartman

    Newbie

  • New Member
  • Pip
  • 5 posts
  • Ford Model: C-Max 2l TDCi

Posted 02 September 2011 - 04:45 PM

Hello,

I have a 55 plate Focus Cmax Ghia Titanium, the problem I am hoping that the forum members can help me with is the Electric Power Steering Pump has a whine its there straight away when the car is started up and it can be heard slowing down after the ignition is switched off. I am sure this is the problem as it the noise cannot be heard when the power supply is pulled on the unit, can the unit be serviced? fluid level is ok.

Thanks For looking

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 Lenny

Lenny

    Retired Moderator

  • FOC Supporters
  • 11,706 posts
  • Name: Leonard
  • Ford Model: Mk2.5 Focus ZetecS 1.6TDCi superleggero
  • Year: 2010
  • Location: Ireland
Contributor

Posted 02 September 2011 - 07:37 PM

Hello,

I have a 55 plate Focus Cmax Ghia Titanium, the problem I am hoping that the forum members can help me with is the Electric Power Steering Pump has a whine its there straight away when the car is started up and it can be heard slowing down after the ignition is switched off. I am sure this is the problem as it the noise cannot be heard when the power supply is pulled on the unit, can the unit be serviced? fluid level is ok.

Thanks For looking

Could be the bearings are worn in the cog that the belt turns,


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users