• Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Share Your Car Experience
      Share Your Car Experience
    • Get Your Club gear
      Get Your Club gear
    • Join Premium & Save
      Join Premium & Save
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Sign in to follow this  
Followers 0
fiesta_lad

Printer Has Gone Dead On Me

3 posts in this topic

Hi everyone turned on printer tonight all the lights came on has usual but i did not get any start up sound like when it loads up. Now is a kodak esp 3250 all in one printer on the little LCD screen that normally has a little scroll menu but the lcd screen is blank white i have tryed to print and nothing is hapening no noise nothing all the light are on but no ones in lol.

Been intouch with kodak done all the usual tests turn of the printer wait 30 seconds turn it back on done that and nothing still the same. So does anyone know what the problem could be anyone with the same printer same issues. It's picked it time to brake down just when i need it. :angry:

Thanks every one alan.

Also just to add the printer is installed onto me laptop and when i plug the printer usb lead into my laptop it's saying printer not detected on my computer.

Share this post


Link to post
Share on other sites
 

are you using the correct power supply? sorry for such a patronising question but its amazing on how much that wacks things out.

try powering the printer by itself, ie, dont connect it to anything...just power.

if the screen stays dead, sounds like its managed to corrupt its firmware...time to take it back to where you bought it and get a replacement (if within the 1 year period)

im an IT Tech for the RAF and get calls about dead peripherals all the time.

Share this post


Link to post
Share on other sites

are you using the correct power supply? sorry for such a patronising question but its amazing on how much that wacks things out.

try powering the printer by itself, ie, dont connect it to anything...just power.

if the screen stays dead, sounds like its managed to corrupt its firmware...time to take it back to where you bought it and get a replacement (if within the 1 year period)

im an IT Tech for the RAF and get calls about dead peripherals all the time.

Hello i've tryed to power it by itself by not pluging it in to my laptop and nothing still white screen dead has a door nail

So it looks like a trip back to the shop i will have 2 dig out the receipt if i can find it lol.

Cheers thanks for your reply.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0