Jump to content


Photo

Mk 3 Diesel Misfire


  • Please log in to reply
2 replies to this topic

#1 oilcan

oilcan

    Member

  • Budding Enthusiast
  • PipPip
  • 11 posts
  • Name: william
  • Ford Model: mondeo
  • Year: 2003
  • Location: Lancashire

Posted 13 September 2011 - 02:47 PM

My mk3 mondeo diesel (130)starts and ticks over perfect,but when driven normally misfires after approx 1500rpm.I took it to a friendly garage for diagnosis, they told me no faults showing up,and advised before taking it back to them to change diesel fuel filter and add some wynnes system cleaner to diesel tank,this I have done and after 150miles still misfiring.I have noticed that if I floor the accelerator when changing gear and keep it floored when in top gear NO misfire,so at the moment I am travellind in the highest gear possible,and when my speed is too fast,foot completely off pedal,then to speed up foot on the floor,if I try to cruise misfires,will appreciate any advice before going back to garage Thanks

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 fishermanfinn

fishermanfinn

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Name: sean
  • Ford Model: mondeo
  • Year: 2001
  • Location: Antrim

Posted 13 September 2011 - 05:23 PM

Hi it's most probably a split egr to intercooler pipe just a small split in it can cause your car to run badly.

#3 oilcan

oilcan

    Member

  • Budding Enthusiast
  • PipPip
  • 11 posts
  • Name: william
  • Ford Model: mondeo
  • Year: 2003
  • Location: Lancashire

Posted 15 September 2011 - 06:20 PM

Thanks for tip on hose will check this w/e


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users