Jump to content


Photo

Clutch Help


  • Please log in to reply
4 replies to this topic

#1 leest170

leest170

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Name: lee
  • Ford Model: Focus ST170
  • Year: 2003
  • Location: Kent

Posted 14 September 2011 - 05:16 PM

Hi All,

I brought a Ford Focus ST170 about 4 months ago and this is my 1st Ford car. I have noticed that sometimes, when changing into a new gear, I maintain my speed (even when I am trying to accelerate) and my Rev counter goes way up, and then settles back down on its own. It doesn't happen all the time, but is now causing me some concern. Any ideas before I start getting thobbed off by some garages!!!

Cheers...

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,543 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 15 September 2011 - 03:38 PM

if this happens in the higer gears more than the lower ones, its usually a sign of the clutch starting to slip.

#3 artscot79

artscot79

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 7,889 posts
  • Name: arthur
  • Ford Model: focus mk2 ti-vct
  • Year: 2006
  • Location: Fife

Posted 15 September 2011 - 04:09 PM

if this happens in the higer gears more than the lower ones, its usually a sign of the clutch starting to slip.


have to second that my old foci did the same slipping clutch revs rise but speed doesnt youre better getting the full kit done clutch and slave cylinder etc if done at ford its all in the pack personally iwould when i had my clutch done after a day the slave cylinder burst its seal and spewed clutch fluid out as it was done at ford they replaced everything at there cost as the clutch was contaminated with fluid tempting to save cash and get it done cheaper but in my case that would have been a false economy

#4 andy_1984

andy_1984

    Feet Under The Table

  • New Member
  • PipPipPipPip
  • 131 posts
  • Ford Model: Focus LX Estate

Posted 15 September 2011 - 10:59 PM

i had a similar issue with rising revs around 1st & 2nd gear and maintained same speed when my coil pack went bad. if you give it full throttle in 4th gear and speed is the same but revs keep climbing then yeah its most probably clutch slip.

dont touch coil pack with engine running i nearly killed myself by accidentally touching it last time.

#5 leest170

leest170

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Name: lee
  • Ford Model: Focus ST170
  • Year: 2003
  • Location: Kent

Posted 16 September 2011 - 07:35 AM

Thanks ppl, I will booj it in and hope for the best!!


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users