Jump to content


Photo

Just Bought A Mk2 Mondeo 1.8 Td....heater U.s?


  • Please log in to reply
2 replies to this topic

#1 Spike Sheppard

Spike Sheppard

    Newbie

  • New Member
  • Pip
  • 3 posts
  • Name: Spike
  • Ford Model: Mondeo Mk 2 Verona 1.8 Diesel
  • Year: 1997
  • Location: Bridgend

Posted 15 September 2011 - 09:25 PM

Hi everyone,

I am no mechanic, so need to pick some brains if possible. I can work my round an engine at a basic level, but things like what an EGR looks like (although I understand how and why it works) have me a little puzzled...I have a Haynes manual on the way so this should help

I have just bought a '97 1.8 TD verona mondeo with 220k on the clock (bargain at £225). When I first got it, it was a bit sluggish so had a look on the forums for some answers. Have seen about EGR fixes and blanking them etc...might try this out at some point; put in a new air filter today (old one was caked solid) and hey presto, better performance!

I will change the fuel filter and fit a new set of glow plugs as it is having trouble on first start but runs fine(ish) when warm.

However, here's my problems

1. Heater only blows cold air out; I have seen suggestions of changing rad water and topping with anti-freeze (can it really be that simple?) or is there something else I should be looking at?
2. Fan only works on number 3 & 4 (1 & 2 settings nothing); does the electric switch thingy behind the glove box need replacing or could it be something else?
3. Is it worth blanking the EGR or is it better to just clean it regularly?

Sorry for the essay and thanks for your time.

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,559 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 16 September 2011 - 07:23 AM

1.your heater blowing cold could be down to a few things,it could be an air lock in the system,the heater matrix blocked not allowing water through or if the temp gauge does not move when warmed up it may be a thermostst stuck open
2.most common cause will be the resistor pack as you say.
3.blocking the valve come down to personal prefrence.

#3 Spike Sheppard

Spike Sheppard

    Newbie

  • New Member
  • Pip
  • 3 posts
  • Name: Spike
  • Ford Model: Mondeo Mk 2 Verona 1.8 Diesel
  • Year: 1997
  • Location: Bridgend

Posted 16 September 2011 - 03:21 PM

Well, today whilst driving on the motorway I turned on the fan, wiggled it a couple of times and lo and behold. Heat!

Must be a sticky flap.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users