Jump to content


Show
Photo
- - - - -

Rattling Window And Peeling Door Seals - First Fixes For The Zetec S


  • Please log in to reply
26 replies to this topic

#16 DieselPig

DieselPig

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 287 posts
  • Ford Model: Fiesta Zetec 1.6 TDCi
  • Year: 2011
  • Location: Gloucestershire

Posted 26 July 2012 - 06:21 PM

All

If you want to fix the peeling seal yourselves (or out of warranty) I suggest you buy a roll of double sided foam tape from Ebay.

My Fiesta suffered the same problem and the mess the dealer monkey made of the repair was shocking.

I cleaned the mess up and did it myself.

Tape was 6mm x 5m from Get Goods bargain at £1.79.

I peeled off the old tape, cleaned the glue off with white spirit, wipe over with meths and put the new tape on, sorted.

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#17 MartynS

MartynS

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 1,007 posts
  • Name: Martyn
  • Ford Model: Fiesta ST2
  • Year: 2013
  • Location: Hampshire

Posted 26 July 2012 - 07:21 PM

Why couldn't it just clip or screw in like everything else!

#18 eyemdee

eyemdee

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 125 posts
  • Name: Ian
  • Ford Model: Fiesta 1.4 Titanium Automatic
  • Year: 2011
  • Location: Nottinghamshire

Posted 27 July 2012 - 01:04 PM

Tape was 6mm x 5m from Get Goods bargain at £1.79.


Found it and ordered it so I now have 2 options to try!. Certainly not worth messing about trying to get a dealer to do it.

#19 eyemdee

eyemdee

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 125 posts
  • Name: Ian
  • Ford Model: Fiesta 1.4 Titanium Automatic
  • Year: 2011
  • Location: Nottinghamshire

Posted 01 August 2012 - 09:14 PM

Tape was 6mm x 5m from Get Goods bargain at £1.79.


Well, that was easy.

Tape arrived today, 5 minutes later no more flapping seal. On mine it was just the vertical rubber seal on the front of the rear door which had come loose at the bottom and was not seating correctly on the B pillar but getting trapped behind the door.

Good as new now.

#20 Froggy72

Froggy72

    Settling In Well

  • New Member
  • PipPipPip
  • 44 posts
  • Name: Ian
  • Ford Model: Fiesta metal
  • Year: 2012
  • Location: Staffordshire

Posted 01 August 2012 - 11:45 PM

I've got a 2012 fiesta and I had a look at my seals today and all they've put on is a small blob of glue every 3 inches. Will definately keep an eye on them.

#21 Ross M

Ross M

    Ross ST

  • Budding Enthusiast
  • PipPipPipPip
  • 102 posts
  • Name: Ross
  • Ford Model: ST2
  • Year: 2013
  • Location: Suffolk

Posted 02 August 2012 - 10:31 AM

This has happened to me, firstly at the bottom of the door and now the top, so needless to say it will be going back. It seems like a poor design to me...

Off topic, has anyone had an issue with the passenger window going up very slowly? My local garage temporarily fixed it by greasing the runners up. I think the motor or regulator is dodgy? Any guys & girls? Sorry to go off topic by the way.

#22 jmbrown91

jmbrown91

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 378 posts
  • Name: James
  • Ford Model: Ford Fiesta Zetec S 1.0 EcoBoost
  • Year: 2013
  • Location: Northamptonshire

Posted 02 August 2012 - 10:39 AM

This has happened to me, firstly at the bottom of the door and now the top, so needless to say it will be going back. It seems like a poor design to me...

Off topic, has anyone had an issue with the passenger window going up very slowly? My local garage temporarily fixed it by greasing the runners up. I think the motor or regulator is dodgy? Any guys & girls? Sorry to go off topic by the way.


Have you got wind deflectors fitted?

#23 Ross M

Ross M

    Ross ST

  • Budding Enthusiast
  • PipPipPipPip
  • 102 posts
  • Name: Ross
  • Ford Model: ST2
  • Year: 2013
  • Location: Suffolk

Posted 02 August 2012 - 10:44 AM

Nope..

#24 jmbrown91

jmbrown91

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 378 posts
  • Name: James
  • Ford Model: Ford Fiesta Zetec S 1.0 EcoBoost
  • Year: 2013
  • Location: Northamptonshire

Posted 02 August 2012 - 11:13 AM

Nope..


Ok that rules that idea out then, just take it back to the dealer saying the issue is still arising and get them to check it out again..

#25 Ross M

Ross M

    Ross ST

  • Budding Enthusiast
  • PipPipPipPip
  • 102 posts
  • Name: Ross
  • Ford Model: ST2
  • Year: 2013
  • Location: Suffolk

Posted 02 August 2012 - 11:15 AM

Yeah it needs to, I wont be fobbed off this time! Cheers for trying to assist me though.

#26 White_ZS_TDCI

White_ZS_TDCI

    Settling In Well

  • New Member
  • PipPipPip
  • 48 posts
  • Name: Craig
  • Ford Model: Fiesta Zetec S TDCI
  • Year: 2010
  • Location: Yorkshire

Posted 02 August 2012 - 09:08 PM

This has happened to me, firstly at the bottom of the door and now the top, so needless to say it will be going back. It seems like a poor design to me...

Off topic, has anyone had an issue with the passenger window going up very slowly? My local garage temporarily fixed it by greasing the runners up. I think the motor or regulator is dodgy? Any guys & girls? Sorry to go off topic by the way.


I have this same problem with my passenger window, and the seal is also coming off at the bottom, which i have had fixed once before! I have also noticed marks on the inside of the window too as if it is dragging against some mechanism and leaving greasy marks on the window....maybe this is why it is slow.

I will be booking in for this looking at in the next week or so, will let you know how i get on.

#27 Ross M

Ross M

    Ross ST

  • Budding Enthusiast
  • PipPipPipPip
  • 102 posts
  • Name: Ross
  • Ford Model: ST2
  • Year: 2013
  • Location: Suffolk

Posted 03 August 2012 - 11:36 AM

I have also booked mine back in with Ford so they can hopefully sort it out properly this time. Once I have it done I will post up results.

For the record, the window dragging on mine has done exactly the same thing. Marks left on the window. :angry:

Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users