Jump to content


Photo

Aww Jeeez Had The Mondeo 2 Months...


  • Please log in to reply
2 replies to this topic

#1 Tori

Tori

    Member

  • New Member
  • PipPip
  • 23 posts
  • Name: Victoria
  • Ford Model: Mondeo ghia x tdci
  • Year: 2005
  • Location: Hertfordshire

Posted 19 September 2011 - 08:45 PM

Bought the mondeo in july, to last me 12 months, stick 40k on the clock and replace with a nice shiny new car....
problem 1.... no reverse lights- reverse switch replaced
problem 2.... struggled sooo hard to get into reverse, some adjustment made by my mechanic
problem 3.... really loud knocking noise from engine- cam tensioner pulley replaced in june with non gen part.. i replaced with gen part- running like a dreammm

problem 4.... if accelerating in 6th gear, flashing glow plugs
problem 5.... engine management and flashing glow plugs randomly coming on and problem accelerating and no turb
problem 6.... took the car to the garage today, car plugged in fired up a fuel fault code, fuel lines changed fuel filter sorted. everything flushed.



5 miles later. car was D E A D... great one. tori the rep out of action
AA man has diagnosed with fuel pump or injector. I have never had so many problems with a car!!!!!

will update on my poor sickly mondeo who will be part exchanged for a VW if its still gonna be naughty in a few months time lol

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 Lenny

Lenny

    Retired Moderator

  • FOC Supporters
  • 11,702 posts
  • Name: Leonard
  • Ford Model: Mk2.5 Focus ZetecS 1.6TDCi superleggero
  • Year: 2010
  • Location: Ireland
Contributor

Posted 20 September 2011 - 08:04 AM

will update on my poor sickly mondeo who will be part exchanged for a VW if its still gonna be naughty in a few months time lol


Hope it get's sorted out for you and Perhaps change where you buy your diesel too.

#3 Tori

Tori

    Member

  • New Member
  • PipPip
  • 23 posts
  • Name: Victoria
  • Ford Model: Mondeo ghia x tdci
  • Year: 2005
  • Location: Hertfordshire

Posted 20 September 2011 - 12:15 PM

looks like its the fuel pump... :-/ 1000 minimum


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users