• Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Get Your Club gear
      Get Your Club gear
    • Share Your Car Experience
      Share Your Car Experience
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Join Premium & Save
      Join Premium & Save


Sign in to follow this  
Followers 0
jasta1966

Galaxy Mk3 Alarm Problems

1 post in this topic

Second post in as many days.......here goes.

The alarm on my mk3 galaxy is malfunctioning. Firstly when the alarm goes off the indicators flash but no sound. Not sure where the sounder is or why its not going off but my normal horn also seems a bit feeble which leads me to think only one of the twin snails is working?

Secondly (and this is not so straight forward), the interior lights are not turning on when I disarm the alarm/open the door sometimes. However I have noticed that when the interior lights work properly I don't get a flashing 'i' symbol on the dash. When the lights do work properly the flashing 'i' doesn't come on at all (and I believe both should work - not one or the other).

Anybody any thoughts - one of my many gremlins!! Would really appreciate your help.

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0