Jump to content


Photo

Orion Engine Problem!!!


  • Please log in to reply
5 replies to this topic

#1 neil d

neil d

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Name: neil
  • Ford Model: orion
  • Year: 1989
  • Location: Tyne and Wear

Posted 22 September 2011 - 07:50 PM

Hi!
I have a 1989 ford orion with a 1600 cvh engine. Problem is it will not tick over - already replaced the carburettor, coil, distributor and the ignition amplifier module. Checked and cleaned all engine earths and engine breathing sytem seems to be working Ok. When the car cuts out, if the ignition is switched off and then straight back on again, the engine picks up. The strange thing is that i replaced a snapped bonnet earth strap and the car ran OK for 2 days without any problems but then started to cut out again. really appreciate any suggestions of where to go next.
Thank you!! Neil d

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 yozzerhughes

yozzerhughes

    Member

  • New Member
  • PipPip
  • 14 posts
  • Name: Michael
  • Ford Model: Fiesta Edge
  • Year: 2009
  • Location: Warwickshire

Posted 23 September 2011 - 06:52 PM

Hi,
Crikey your car is a blast from the past, i used too have a F 1988 1.4 lx orion. earthing can be a major problem on them due too there prone too rust, check all earths lights etc, i bet your loving the rust on the rear arches, got too say even though it was a rust bucket it was the 1 car i owned that mechanically never let me down, even on the long journeys to germany when i was posted there.
Mick

#3 yozzerhughes

yozzerhughes

    Member

  • New Member
  • PipPip
  • 14 posts
  • Name: Michael
  • Ford Model: Fiesta Edge
  • Year: 2009
  • Location: Warwickshire

Posted 23 September 2011 - 06:56 PM

Hi!
I have a 1989 ford orion with a 1600 cvh engine. Problem is it will not tick over - already replaced the carburettor, coil, distributor and the ignition amplifier module. Checked and cleaned all engine earths and engine breathing sytem seems to be working Ok. When the car cuts out, if the ignition is switched off and then straight back on again, the engine picks up. The strange thing is that i replaced a snapped bonnet earth strap and the car ran OK for 2 days without any problems but then started to cut out again. really appreciate any suggestions of where to go next.
Thank you!! Neil d


Hi again
on another note, due too it has carburettors, you need an inline fuel put in by yoursself or garage and you probably need the carb blasted through with compressed air, the fuel tanks on them love collecting crap then dumping them through the carb, its a bugger for idling.
Mick

#4 neil d

neil d

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Name: neil
  • Ford Model: orion
  • Year: 1989
  • Location: Tyne and Wear

Posted 23 September 2011 - 07:54 PM

Hi again
on another note, due too it has carburettors, you need an inline fuel put in by yoursself or garage and you probably need the carb blasted through with compressed air, the fuel tanks on them love collecting crap then dumping them through the carb, its a bugger for idling.
Mick

Thanx for that- will give it a go!! I'll let you know wot happens!!!
Cheers1
neil!

#5 sizak

sizak

    Member

  • New Member
  • PipPip
  • 24 posts
  • Name: simon
  • Ford Model: focus
  • Year: 2002
  • Location: Shropshire

Posted 02 October 2011 - 11:54 AM

fuel tank filter could be blocked?

#6 mr pompey

mr pompey

    Settling In Well

  • New Member
  • PipPipPip
  • 81 posts
  • Ford Model: st24

Posted 02 October 2011 - 05:10 PM

being a cvh engine, it could be a breather pipe blocking up,

Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users