Jump to content


Photo

Speedo And Eningie Troubles


  • Please log in to reply
6 replies to this topic

#1 M4V3R1CK86

M4V3R1CK86

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Name: Greg
  • Ford Model: focus
  • Year: 2000
  • Location: Essex

Posted 24 September 2011 - 11:47 AM

PLEASE HELP me i own a foucs giha 2.0 X Reg and starting to wish i didnt.

the problems i'm having are when your driving along and the speedo drops out, you will be driving for a few miles more and then it picks it self up and on the odd occasion my mileage goes blank and again that might pick it self back up but the car will drive fine but the is a big BUT!
The car likes to die on you when coming up to a junction and slowing your self down and to a stop.

When the car dies its like your stalling it but im not as i will have my foot down on the clutch to the floor when in gear.
You wont feel the car die on you just get the lights on the dash showing you ignition, battery and oil light.
Turn the whole car off and restart it and be fine execpt the speedo that still might be out.

with all these problems im getting im starting to think its a eletrical fault as one of my interior light stopped working for a while then now started working and as the car has central locking and being a 5 door the back doors lock/unlock when they feel like which is hardly ever.

I've had the car for about 7 months and starting to regret it

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 fishpond 47

fishpond 47

    Feet Under The Table

  • FOC Supporters
  • 363 posts
  • Ford Model: mk3 mondeo x2 + a ka

Posted 24 September 2011 - 04:34 PM

I'd start with the simple things first, check the battery connections are clean and tight, get the battery checked for holding it's voltage.

#3 Jouxy

Jouxy

    Member

  • New Member
  • PipPip
  • 27 posts
  • Ford Model: Mondeo

Posted 24 September 2011 - 10:44 PM

PLEASE HELP me i own a foucs giha 2.0 X Reg and starting to wish i didnt.

the problems i'm having are when your driving along and the speedo drops out, you will be driving for a few miles more and then it picks it self up and on the odd occasion my mileage goes blank and again that might pick it self back up but the car will drive fine but the is a big BUT!
The car likes to die on you when coming up to a junction and slowing your self down and to a stop.

When the car dies its like your stalling it but im not as i will have my foot down on the clutch to the floor when in gear.
You wont feel the car die on you just get the lights on the dash showing you ignition, battery and oil light.
Turn the whole car off and restart it and be fine execpt the speedo that still might be out.

with all these problems im getting im starting to think its a eletrical fault as one of my interior light stopped working for a while then now started working and as the car has central locking and being a 5 door the back doors lock/unlock when they feel like which is hardly ever.

I've had the car for about 7 months and starting to regret it



#4 Jouxy

Jouxy

    Member

  • New Member
  • PipPip
  • 27 posts
  • Ford Model: Mondeo

Posted 24 September 2011 - 10:51 PM

Hi, the problem will lie with the speedo sensor in the gearbox, it is a hall effect sensor (has no moving parts) this will cause the speedo to drop the odometer to show dashes and the engine management has no speed information this causes the vehicle to stall, this has nothing to do with the other problems, they are difficult to remove from the gearbox. Hope this helps.

#5 MrRedman

MrRedman

    Settling In Well

  • Budding Enthusiast
  • PipPipPip
  • 91 posts
  • Name: Paul
  • Ford Model: focus 2002
  • Year: 2002
  • Location: Lancashire

Posted 25 September 2011 - 10:11 AM

Yep its the speed sensor on the gearbox my radio also went lower when the other things were occuring pay the garage to do it its not expensive,if
you do it yourself it may snap then you have a problem! :o

#6 sizak

sizak

    Member

  • New Member
  • PipPip
  • 24 posts
  • Name: simon
  • Ford Model: focus
  • Year: 2002
  • Location: Shropshire

Posted 25 September 2011 - 11:31 AM

PLEASE HELP me i own a foucs giha 2.0 X Reg and starting to wish i didnt.

the problems i'm having are when your driving along and the speedo drops out, you will be driving for a few miles more and then it picks it self up and on the odd occasion my mileage goes blank and again that might pick it self back up but the car will drive fine but the is a big BUT!
The car likes to die on you when coming up to a junction and slowing your self down and to a stop.

When the car dies its like your stalling it but im not as i will have my foot down on the clutch to the floor when in gear.
You wont feel the car die on you just get the lights on the dash showing you ignition, battery and oil light.
Turn the whole car off and restart it and be fine execpt the speedo that still might be out.

with all these problems im getting im starting to think its a eletrical fault as one of my interior light stopped working for a while then now started working and as the car has central locking and being a 5 door the back doors lock/unlock when they feel like which is hardly ever.

I've had the car for about 7 months and starting to regret it



#7 sizak

sizak

    Member

  • New Member
  • PipPip
  • 24 posts
  • Name: simon
  • Ford Model: focus
  • Year: 2002
  • Location: Shropshire

Posted 25 September 2011 - 11:33 AM

hi.i have heard once an earth wire on the right hand sill for the fuel pump can come lose.

Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users