Jump to content


Photo

Kuga Cuts Out When Accelerating


  • Please log in to reply
4 replies to this topic

#1 sizak

sizak

    Member

  • New Member
  • PipPip
  • 24 posts
  • Name: simon
  • Ford Model: focus
  • Year: 2002
  • Location: Shropshire

Posted 25 September 2011 - 11:27 AM

hi,i know someone who has a 09 plate kuga and it cuts out on hard acceleration and the tcs light comes on.any ideas?on restart ok and driven lightly not a problem.no visible air leaks or other concerns.

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 ChristopherRingham

ChristopherRingham

    Newbie

  • Members via FB
  • Pip
  • 9 posts
  • Name: Christopher
  • Ford Model: Focus 1.6 TDCi Zetec
  • Year: 2011
  • Location: Other / Non-UK

Posted 25 September 2011 - 09:05 PM

hi,i know someone who has a 09 plate kuga and it cuts out on hard acceleration and the tcs light comes on.any ideas?on restart ok and driven lightly not a problem.no visible air leaks or other concerns.


Is it the TCS light that comes on or the EML light? If it's the EML it sounds like it could be the DPF if its a diesel - we've had a few of these at the dealership I work at

#3 Lenny

Lenny

    Retired Moderator

  • FOC Supporters
  • 11,672 posts
  • Name: Leonard
  • Ford Model: Mk2.5 Focus ZetecS 1.6TDCi superleggero
  • Year: 2010
  • Location: Ireland
Contributor

Posted 26 September 2011 - 12:04 AM

Try changing the place they buy the fuel from as the Octaine in it may not be as it should be



#4 sizak

sizak

    Member

  • New Member
  • PipPip
  • 24 posts
  • Name: simon
  • Ford Model: focus
  • Year: 2002
  • Location: Shropshire

Posted 26 September 2011 - 07:01 PM

tcs light.
found out today one of the injectors was having apparently too much leak off.causing the module to shutdown on throttle.new one being fitted soon.

#5 sizak

sizak

    Member

  • New Member
  • PipPip
  • 24 posts
  • Name: simon
  • Ford Model: focus
  • Year: 2002
  • Location: Shropshire

Posted 30 September 2011 - 08:58 AM

finally checked the fuel filter.it had only done 19,000 miles....sand..filter and housing full of sand contamination.requires full fuel system clean out .tank off.filter housing off which includes having to remove inlet manifold.for fuel tank removal propshaft removal. what a job...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users