Jump to content


Photo

Fiesta Mk6 Triple Deck Stereo Removal


  • Please log in to reply
32 replies to this topic

#31 manwithtool

manwithtool

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Name: Martin
  • Ford Model: Fiesta
  • Year: 2006
  • Location: Hertfordshire

Posted 19 November 2014 - 11:05 PM

Hi Guys, new to the forum.  My son has just bought a 1.4 Fiesta Mk6 2006.  Done all of the above and have the stereo fitted, but it is not storing radio stations or the clock.  Seems it doesn't have a permanent live working.  Any ideas.  I used the Autoleads PC2-80-4.

 

Could it be a blown fuse to the radio ? 



Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#32 Stoney871

Stoney871

    Resident Peacekeeper

  • Super Mod
  • 15,552 posts
  • Name: Clive
  • Ford Model: Focus mk2 1.8 TDCI Sport
  • Year: 2007
  • Location: Devon
Contributor

Posted 19 November 2014 - 11:29 PM

You may need to swap the permanent live and ignition live feeds over.
Do you have a connector diagram with your radio?

#33 GingerFlame

GingerFlame

    Feet Under The Table

  • FOC Supporters
  • 182 posts
  • Name: Kieran
  • Ford Model: Fiesta mk6
  • Year: 2004
  • Location: Yorkshire

Posted 19 November 2014 - 11:29 PM

Could be a blown fuse, or the positive and the switched positive could be the wrong way around?

The connector in the back of the radio may be faulty? Or maybe even the battery is just low on power?


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users