Jump to content


Photo

Turbo Problems


  • Please log in to reply
1 reply to this topic

#1 klouise77

klouise77

    Newbie

  • New Member
  • Pip
  • 5 posts
  • Name: Kerry
  • Ford Model: Focus 1.8TD
  • Year: 2006
  • Location: Shropshire

Posted 01 October 2011 - 04:10 AM

Hello ,

im new to this so sorry if in wrong section

Bought a focus 2006 1.8 td a few months ago and it does have some warranty on it but i have to pay and claim back , however the engine light keeps coming on so took it to ford and the problem is P0299 turbo under boost , they had it 2 days and couldn't find the fault and said it was ok , paid the diagnostic drove it that night and comes on again!! they said to try it for a few days and if happened poss look at new turbo. Trouble is there , touch wood so far, is no loss in power, smoke that would suggest the turbo could be on way out it drives fine??! anyone help?!

thanks in advance

Kez

Have something to contribute?

Sign in or register to start a topic...

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,457 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 01 October 2011 - 04:55 PM

check all the rubber pipes you can find for any splits or leakage.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users