AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Climbatize

Help: A Few Problems With My Puma

3 posts in this topic

Hi there,

First time here - I found out about this place from the pumapeople forum.

I have a couple of issues with my Puma which I'm looking for some advice on, I've booked my car into a Ford dealership for a full service next week but I'd like to get some additional information in preperation.

Besides the car needing serviced I have the following faults, in which I'd appreciate if 1. Is it expensive to repair, and roughly how much am I looking at and 2. Is it difficult to identify the cause.

1. The passenger side electric mirror does not go up or down.

2. The speedometer stopped working 2 days ago.

3. The engine light lit up on the dashboard today - could this because of the speedometer?

4. The remote key fobs sometimes won't work unless I get quite close to the car, is this just a case of replacing the battery and a weak signal as a result?

My Puma is a 1.7 late 2001 model and only has 30k miles.

Thanks

Share this post


Link to post
Share on other sites
 

1. The contacts in the mirror may have corroded or the motor has siezed, They get so little use they often do this. I swopped my motor over with one from a Mk 5 Fiesta and it worked fine.

2. Not sure about your speedo. If it is driven by an electronic pickup, it may be that that is faulty. If you hold down the milometer trip button while you turn the ignition on, see if that does a self check.

3. Dash warning light needs a reader plugging in to check whats causing it to come on.

4. Yours may have the older system, same as the Ka, and the signal is quite weak on these and you do need to be near the car. Even worse on hot sunny days.

Share this post


Link to post
Share on other sites

1. The contacts in the mirror may have corroded or the motor has siezed, They get so little use they often do this. I swopped my motor over with one from a Mk 5 Fiesta and it worked fine.

2. Not sure about your speedo. If it is driven by an electronic pickup, it may be that that is faulty. If you hold down the milometer trip button while you turn the ignition on, see if that does a self check.

3. Dash warning light needs a reader plugging in to check whats causing it to come on.

4. Yours may have the older system, same as the Ka, and the signal is quite weak on these and you do need to be near the car. Even worse on hot sunny days.

Thanks for the advice, I'll certainly try the trip button and report back.

Someone else (on another forum) has mentioned rust on the inside mirror, and regarding the engine light - they had suggested because my milage was digital, that it is possibly related. Like you said though, I will find out when I take it in on Friday.

Shame if thats the case re: signal

Thanks for your help

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now