• Huge Range of Ford Parts
      Huge Range of Ford Parts
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Get Your Club gear
      Get Your Club gear
    • Share Your Car Experience
      Share Your Car Experience
    • Join Premium & Save
      Join Premium & Save
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members


sportiva.t35.com

Sierra 2.0I Efi Wont Start

2 posts in this topic

Hi!

The problem is s the title says. The car is model a year 1991 2.0i OHC (PINTO) engine with EEC IV EFI with HEGO (lambda) and catalytic converter (witch BTW was removed by the previous owner). The car runs on petrol and LPG. Before the problem the car had some hesitation when accelerating while driving on petrol and on LPG was running fine.

Yesterday I was fitting a new rear exhaust silencer. After I welded the silencer I turned the engine on to check if the weld was good. The engine did run fine. After that I lowered the car and removed the jack stand. Tried to start the engine again and now the engine cranks but wont start either using petrol or LPG

I checked the ignition by pulling a spark plug wire off of a spark plug and placed the open end of the plug wire near a metal surface on the engine. My m8 cranked the engine while I watched for a spark and there was sparks.

When the LPG system is switched to petrol and I turn the ignition key I hear the pump working and when I switch to LPG mode I hear the LPG solenoid open.

My guess is that the compression is OK as the timing belt is in place.

Any suggestions on what could be wrong?

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now