AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


billy181271

MONDEO TDC1 130 NO REVVING

3 posts in this topic

Hi

Can someone help please!!!!!!!!!!!!!!!!!!!!!!!

I have a 2002 tdci 130

In September I changed my blown engine , with an engine out of a 2004 tdci 130. I letf the injectors and fuel pump etc that came with the replacement engine on. I had the injectors programmed by ford.

Also changed DMF with clutch.

Now the bad bit the engine always started even before programming by ford.

The car starts and idles at 650 rpm with bat light on. It can stay running until bat runs out. In the mean time the engine is smoking etc as it is running lumpy. Then suddenly on occassions the engine revs pickup to 900rpm and you can start to rev engine asusal. The engine starts sounds sweet smokey but it does clear. Once running you can drive car and it is on power etc. Turn the engine off and on again goes back to revving at 650rpm and you can't rev it.

Whilst its been cold you can start car and it starts to rev as normal coughin and farting then clears out. turn engine off and it goes back to not revving. Also when it is not revving you can put it into gear and labour engine and it starts to rev then turn it off etc same old same old agian.

Have changed cam,crank,maf,pressure sensor etc no joy

ANY IDEAS PLEASE 07971864236

Share this post


Link to post
Share on other sites
 

Hi mate do you not have a local mobile diagnostics? you could be guessing and changing parts needlessly and cost you a fortune.

steve

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now