Jump to content


Show
Photo

Please Help


  • Please log in to reply
1 reply to this topic

#1 trbjones

trbjones

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Ford Model: 2001 cl 1.4
  • Location:

Posted 06 January 2009 - 11:36 AM

First let me say what a great site for help and information

HI there I need your help my Speedo was going from 30 to 140 then back down to 0 and the temperature and fuel gauge was going up and down all other the places, then it would be ok for 30 mins then play up again. I went to ford and they charged me 60 for a diagnose and said it would need a new cluster

The next day my head lights went on my car and I opened up to see the plastic at the back had all be melted. The local grauge said that I would need a new alternator fitted as it was Charing at 18.5 volts instead of 14 volts they also said that that might be make my Speedo to play up due to the fact that if the voltage is go's high or lowthe Speedo dose at self reboot/ diagnoses test. I had a new alternator and battery fitted and the car worked great for about 30 mins

Then the car lost all power and would not restart, the rac took me back to the gauge and they checked the alternator and said every think was fine and they don't know whets wrong with it still the battery light still go's on and off but the Speedo is now working fine. please help

sorry about the spelling any help would be great

N.JONES

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,461 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 07 January 2009 - 03:57 PM

have you checked for any bad earth contacts around the alternator and battery?


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users