Jump to content


Photo
- - - - -

Fiesta 1.25 Water Not Circulating


  • Please log in to reply
No replies to this topic

#1 stuartadair

stuartadair

    Newbie

  • New Member
  • Pip
  • 9 posts
  • Ford Model: Fusion
  • Location:

Posted 21 October 2011 - 03:15 PM

Hello all

P Reg Fiesta 1.25 just put a replacement engine in. Engine runs well however it doesnt appear that water is circulating as it should.

Symptoms: Engine temperature reads normal/high. Both heater hoses hot where they go into the heater control on the bulkhead although heater is blowing cold air. Top and Bottom hoses, radiator both cold.

I've removed the thermostat housing and all appears to be ok. Blown through as many pipes as I can and all seems to be flowing. I can feel the back of the water pump through the thermostat housing space and the rotor feels ok, its turning with the pulley.

2 theories so far that I would like your opinion about...

a) The new engine originally had a power steering pump, old engine did not. I took the pump off and used the old belt. Could I have buggered up the belt routing so that the water pump is turning the wrong way? Its currently rotating anti-clockwise. Do the water pumps on non power steering cars rotate differently to power steering cars ?

B) Heater control unit water connector collapsed as soon as I pulled the pipes off so I need to replace this. The r/h pipe has a control arm which appeared to be closed. Does this completely block the flow of water around the engine.

Or perhaps something else I havent thought of...

Anyway, sorry for the long post but I wanted to give you as much info as possible

stu

Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users