Jump to content


Power Steering Problems

  • Please log in to reply
2 replies to this topic

#1 petefren



  • New Member
  • Pip
  • 1 posts
  • Name: Peter
  • Ford Model: Mondeo Titanium X 2.5T
  • Year: 2007
  • Location: Lincolnshire

Posted 21 October 2011 - 04:45 PM

Hi Everyone,

loads of info on here, but not finding a solution to my problem, maybe the "newbie" isnt looking hard enough.

My 07 Mondeo Titanium x 2.5T has an issue with her power steering. It seems to be very stiff at very low speed, like when I change between 1st and reverse. I have had her upto 150mph (legally) and the steering is spot on and very responsive, its just a pain when trying to pull away or park.

Any help or ideas would be really appreciated.



Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 alz


    Serial Poster

  • Budding Enthusiast
  • PipPipPipPip
  • 460 posts
  • Name: Alan
  • Ford Model: Ford Focus LX 1.8 TDCI
  • Year: 2005
  • Location: Worcestershire

Posted 24 October 2011 - 07:44 PM

Hi Pete, Have you checked the tyre pressures. also I am not to sure if the mondeo uses the drive belt or an electric motor to work the steering pump, if it is the belt driving the pump it could be sliping at low revs giving you reduced power to the rack until you speed up.. if its electric it could need changing

#3 fishpond 47

fishpond 47

    Feet Under The Table

  • FOC Supporters
  • 363 posts
  • Ford Model: mk3 mondeo x2 + a ka

Posted 25 October 2011 - 07:46 PM

and have you checked the obvious, .....power steering fluid

Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users