Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Sign in to follow this  
Followers 0
jackrc18

Loss of power /little torque

3 posts in this topic

My old Mk1 (93) 1,8 GLX needs nursing through the next three months before waving goodbye :( but it has suddenly has no power. Pulling away it takes an eternity to build up speed and going uphill is a severe struggle. It revs high but not much in return. Suggestions/ P.S. Plugs and leads and fuel filter OK.

Share this post


Link to post
Share on other sites
 

Sounds like its popped into 'limp home' mode. Only sure fire way of telling why is getting it on the code reader pal.

Share this post


Link to post
Share on other sites

I have checked it with reading the pulses on an analogue meter, codes all clear.... I now think its a dead clutch and depending on cost may mean its "outta here" :unsure:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0