Jump to content


Photo

03 Fiesta Tdci Won't Start Help!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!


  • Please log in to reply
5 replies to this topic

#1 FF1.4

FF1.4

    Newbie

  • New Member
  • Pip
  • 3 posts
  • Name: Ollie
  • Ford Model: Fiesta
  • Year: 2003
  • Location: Hampshire

Posted 25 October 2011 - 06:58 PM

Hello all,

I have an 03 fiesta TDCI that is playing up when starting, when I turn the key nothing happens apart from 2 lights coming up on the dash, but then sometimes after a couple of attempts it will go and others it won't. Any ideas? Cheers

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 alz

alz

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 402 posts
  • Name: Alan
  • Ford Model: Ford Focus LX 1.8 TDCI
  • Year: 2005
  • Location: Worcestershire

Posted 25 October 2011 - 07:36 PM

Hi Ollie , When you say nothing happens, will it turn over.

#3 FF1.4

FF1.4

    Newbie

  • New Member
  • Pip
  • 3 posts
  • Name: Ollie
  • Ford Model: Fiesta
  • Year: 2003
  • Location: Hampshire

Posted 26 October 2011 - 09:47 AM

Alan,

No it won't turn over at all and the electrics don't work, but like I said then out of the blue I'll turn the key and it will start perfectly!?

#4 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,466 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 26 October 2011 - 02:50 PM

first thing to do is check all the electrical connections around the battery and starter motor to see if they are clean and tight.

#5 alz

alz

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 402 posts
  • Name: Alan
  • Ford Model: Ford Focus LX 1.8 TDCI
  • Year: 2005
  • Location: Worcestershire

Posted 26 October 2011 - 03:36 PM

Just a mintalkin says, it must be something lose. disconnect the battery frist before you start tighting things up so that you don't short out anything, connect the battery last

#6 FF1.4

FF1.4

    Newbie

  • New Member
  • Pip
  • 3 posts
  • Name: Ollie
  • Ford Model: Fiesta
  • Year: 2003
  • Location: Hampshire

Posted 26 October 2011 - 05:11 PM

Thanks for the replys. All the connections are fine, My mechanic took the battery off and played with the relays and it worked well for a week but now it's started playing up again. And to make things worse I changed the battery in my cobra key fob and now it won't unlock. Ive tried holding both buttons for 10 seconds which won't work either.

Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users