Jump to content


Photo

Fiesta Flight Misfire :(


  • Please log in to reply
1 reply to this topic

#1 cayongrayoo

cayongrayoo

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: Fiesta Flight

Posted 26 October 2011 - 12:48 PM

It's a fiesta flight 1.3l 2001. done 127000 miles.
ever since I've had it it has had a misfire when throttle increased dramatically. Tried new ht leads cols and sparks which temporarily fixed the problem. But I've grown accustomed to that.
yesterday I was driving in the rain, admittedly through a few deepish puddles, and it started misfiring at much lower revs. in fact it misfired every time i put my foot on the pedal. Only one cylinder was missing though. it would also misfire on idle. engine warning light came on.
Today warning light still on but doesn't misfire on idle and is pretty much back to the normal misfire when throttle increased dramatically.
Was is just because it was damp? and shorting out somewhere?
and how do i reset the engine warning light? considered disconnecting battery but i don't want to disable my stereo as I dont have the codes..i donth think.
Thanks in advance.

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 btmaldon

btmaldon

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 2,581 posts
  • Name: Bruce
  • Ford Model: BMW 320i Coupe M Sport, KA Luxury
  • Year: 2008
  • Location: Essex

Posted 26 October 2011 - 08:44 PM

Try reconnecting the HT leads, ensuring they are not touching any metal parts, which may be causing a short and that the connections are tight. Then give them a good coating of ignition sealant/damp start.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users