AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


muggo

Mondeo Mk3 Washer Pump

4 posts in this topic

Hiya

My washers don't work too well as, after the inital jet onto the screen, it just dribbles. If I press the button again, the same thing happens. It should be better than this.

My mate suggested it may be a blockage & the quickest way to sort it would be to force compressed air up the pipe from the front washers & flush the blockage backwards through the pump & into the reservoir. I tried this & succeeded in forcing off the pipe that goes into the reservoir. Therefore I need to access the pump to refit the pipe.

Do I need to remove the O/S/F wheel & wheel arch liner to access it, or is there a quicker way? I hope there's a shortcut!

Thanks very much.

Paul

Share this post


Link to post
Share on other sites
 

you might be able to access the pipe by jacking up the front of the car,use axle stands to support the car if crawling underneath.

Share this post


Link to post
Share on other sites

you might be able to access the pipe by jacking up the front of the car,use axle stands to support the car if crawling underneath.

Thanks mate.

I've had a look underneath, but even if it were on a ramp, there's no way I could get my hands into any holes. Do I have to remove a penel somewhere to give me some room?

Share this post


Link to post
Share on other sites

if the underside is blocked the only way is by the wheel lining as you said

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now