Jump to content


Photo

Mk3 Focus Tdci


  • Please log in to reply
17 replies to this topic

#1 fernsie

fernsie

    Settling In Well

  • New Member
  • PipPipPip
  • 87 posts
  • Name: Stephen
  • Ford Model: Focus 1.6 TDCi Zetec
  • Year: 2011
  • Location: WestLothian

Posted 03 November 2011 - 08:45 PM

Hi guys,

Another question for anyone with a MK3 TDCi ... does your car have a glow plug light on the dash?

In my MK2 I was used to waiting until the glow plug light had gone out before attempting to start the car, however, I do not have a glow plug light on the dash of my MK3 ... is this just me?


Cheers

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 tomo2001

tomo2001

    Serial Poster

  • Budding Enthusiast
  • PipPipPipPip
  • 485 posts
  • Name: Paul
  • Ford Model: Ford Focus 1.6 TDCi Titanium X
  • Year: 2011
  • Location: Yorkshire

Posted 03 November 2011 - 10:06 PM

Doesn't have a glow plug light as such on the Titanium X but when the engine is cold and you first turn on the ignition, a glow plug symbol pops up and says engine preheating.

#3 fernsie

fernsie

    Settling In Well

  • New Member
  • PipPipPip
  • 87 posts
  • Name: Stephen
  • Ford Model: Focus 1.6 TDCi Zetec
  • Year: 2011
  • Location: WestLothian

Posted 03 November 2011 - 10:38 PM

Thanks for that.

I have never seen the glow plug light yet. Wonder if it will apear when it gets colder further into winter

#4 cuke

cuke

    Too much time on the boards

  • True Ford Enthusiast
  • PipPipPipPip
  • 731 posts
  • Name: Chris
  • Ford Model: Mk3 Focus Titanium X
  • Year: 2011
  • Location: Sussex

Posted 04 November 2011 - 10:42 AM

Hi, I doubt very much if it has been cold enough for any need for the engine to use the glowplugs. My 2.0l Mondeo diesel rarely seem to need to use them.
Chris

#5 jeebowhite

jeebowhite

    Resident Loon

  • Super Mod
  • 21,145 posts
  • Name: James
  • Ford Model: Sea Grey Mondeo MKIV 1.8TDCi 140ps Zetec
  • Year: 2007
  • Location: Kent
Contributor

Posted 04 November 2011 - 02:34 PM

Thanks for that.

I have never seen the glow plug light yet. Wonder if it will apear when it gets colder further into winter


Nope that will be the red snowflake.... oh how I miss that little icon...

#6 Barry_

Barry_

    Feet Under The Table

  • New Member
  • PipPipPipPip
  • 183 posts
  • Name: Baz
  • Ford Model: Focus 1.8 TDCI Titanium
  • Year: 2006
  • Location: Hampshire

Posted 04 November 2011 - 03:17 PM

LOL - Actually thought about that yesterday morning and thought what the hell does that mean - Meant to check my user book at home but forgot!!

Would you like me to sent you a pic of it - would you like both orange and red versions :P

#7 jeebowhite

jeebowhite

    Resident Loon

  • Super Mod
  • 21,145 posts
  • Name: James
  • Ford Model: Sea Grey Mondeo MKIV 1.8TDCi 140ps Zetec
  • Year: 2007
  • Location: Kent
Contributor

Posted 07 November 2011 - 02:07 PM

Please do! I will print it off and stick it to my Cee'd... lol

what was it... under 5 - Orange, under 0 - Red?

#8 Barry_

Barry_

    Feet Under The Table

  • New Member
  • PipPipPipPip
  • 183 posts
  • Name: Baz
  • Ford Model: Focus 1.8 TDCI Titanium
  • Year: 2006
  • Location: Hampshire

Posted 07 November 2011 - 02:46 PM

LOL - still not checked to be honest.. Will do tonight so i don't freak out when it pops up one day and i ain't got a clue what its for.

Guess its just a sign to say its cold - in case your incapable of reading the onscreen temp reading :lol:

#9 fernsie

fernsie

    Settling In Well

  • New Member
  • PipPipPip
  • 87 posts
  • Name: Stephen
  • Ford Model: Focus 1.6 TDCi Zetec
  • Year: 2011
  • Location: WestLothian

Posted 07 November 2011 - 03:09 PM

Been on up here. Had both Red and Orange today ... still no Glow Plug light though and it was 0 when I left the house this morning!!

#10 fernsie

fernsie

    Settling In Well

  • New Member
  • PipPipPip
  • 87 posts
  • Name: Stephen
  • Ford Model: Focus 1.6 TDCi Zetec
  • Year: 2011
  • Location: WestLothian

Posted 08 November 2011 - 09:46 PM

Phoned Ford today for a definitive answer ... no luck there!

Guy I spoke to checked one of Fords own company cars and talked to the guy that drives it (service manager)
- The guy I spoke to did not see a glow plug light and the guy that drives it does not remember seeing one

The manual does note that there should be one, so the guy says he will look into this for me and get back to me ... may not be for a while though


**Could a MOD change the subject heading of this to add the words 'Glow Plug Light' on the end??

#11 Preee

Preee

    Ford Fruitcake

  • Moderator
  • 4,374 posts
  • Name: Paul
  • Ford Model: Focus Tit X Mk3.5 | Fiesta Zetec Mk7
  • Year: 2015
  • Location: Shropshire
Contributor

Posted 08 November 2011 - 11:52 PM

**Could a MOD change the subject heading of this to add the words 'Glow Plug Light' on the end??


You can Edit the title by selecting edit on your first post and then selecting to use Full editor , well i can as a FOC Supporter not sure as a standard user

#12 fernsie

fernsie

    Settling In Well

  • New Member
  • PipPipPip
  • 87 posts
  • Name: Stephen
  • Ford Model: Focus 1.6 TDCi Zetec
  • Year: 2011
  • Location: WestLothian

Posted 09 November 2011 - 12:00 AM

You can Edit the title by selecting edit on your first post and then selecting to use Full editor , well i can as a FOC Supporter not sure as a standard user


Thanks

I don't seem to be able too :(

#13 Preee

Preee

    Ford Fruitcake

  • Moderator
  • 4,374 posts
  • Name: Paul
  • Ford Model: Focus Tit X Mk3.5 | Fiesta Zetec Mk7
  • Year: 2015
  • Location: Shropshire
Contributor

Posted 09 November 2011 - 12:11 AM

Thanks

I don't seem to be able too :(


Ok must be a perk of the FOC membership only .

#14 cuke

cuke

    Too much time on the boards

  • True Ford Enthusiast
  • PipPipPipPip
  • 731 posts
  • Name: Chris
  • Ford Model: Mk3 Focus Titanium X
  • Year: 2011
  • Location: Sussex

Posted 09 November 2011 - 07:45 AM

Been on up here. Had both Red and Orange today ... still no Glow Plug light though and it was 0 when I left the house this morning!!


Hi, even if it's 0c you might not see this light due to the temps not being cold enough. I never saw mine, and when I did it was briefly, until the temps got down to below -4c.
Chris

#15 fernsie

fernsie

    Settling In Well

  • New Member
  • PipPipPip
  • 87 posts
  • Name: Stephen
  • Ford Model: Focus 1.6 TDCi Zetec
  • Year: 2011
  • Location: WestLothian

Posted 09 November 2011 - 12:20 PM

Hi, even if it's 0c you might not see this light due to the temps not being cold enough. I never saw mine, and when I did it was briefly, until the temps got down to below -4c.
Chris


Thanks Cuke. When has it ever been below -4C in Sussex though since the MK3 has been released!!

Anyway, car is running fine, so i'm not fussed whether it comes on, or not ... glad to know it at least exists though, so i'll keep an eye out for it

Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users