• Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Get Your Club gear
      Get Your Club gear
    • Join Premium & Save
      Join Premium & Save
    • Share Your Car Experience
      Share Your Car Experience
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Huge Range of Ford Parts
      Huge Range of Ford Parts

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Azeluk

Ford Galaxy Parking Sensors

1 post in this topic

Hi Peeps,

I'm new to the forum and to fords in general, i've just become the proud owner of a 2003 1.9tdi Galaxy, unfortunatly i have noticed that the front and rear parking sensors arn't working, i have contacted the garage who have said they will fix the problem but to save time i was hoping some one could tell me what the problem is so i can pass the details on.

The symptoms are : placing the car in reverse the parking sensor button on the control panel flashes, if i turn it off and back on there is one long beep and the button starts flashing again.

Any advice would be very much appreciated.

Many thanks.

Azel.

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now