• 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Share Your Car Experience
      Share Your Car Experience
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Get Your Club gear
      Get Your Club gear
    • Join Premium & Save
      Join Premium & Save
    • Huge Range of Ford Parts
      Huge Range of Ford Parts


jts

Power Loss

3 posts in this topic

Hi, I had a loss of power over the weekend with our 07 s-max 2.0 tdci, the engine malfunction light came on and it was as if the engine had literally lost half its power. It still drove, but pretty slowly.

I managed to drive the 2 miles home, then the following day it was back to normal, no engine malfunction light and back to full power.

Has anyone experienced anything like this before?

Any advice would be appreciated, obviously I guess I should take it in, but if it is working fine now, will the garage be able to diagnose a fault?

Share this post


Link to post
Share on other sites
 

Yes a garage should be able to diagnose the fault, if the engine management light was on the a fault code would have been stored. However after a while the code will be erased, if the fault has not reoccurred.

Share this post


Link to post
Share on other sites

the loss of power is normal when the e.m.l is on its called limp home mode,it could be a one off but as mentioned i would get the codes read to be sure.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now