Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


jts

Power Loss

3 posts in this topic

Hi, I had a loss of power over the weekend with our 07 s-max 2.0 tdci, the engine malfunction light came on and it was as if the engine had literally lost half its power. It still drove, but pretty slowly.

I managed to drive the 2 miles home, then the following day it was back to normal, no engine malfunction light and back to full power.

Has anyone experienced anything like this before?

Any advice would be appreciated, obviously I guess I should take it in, but if it is working fine now, will the garage be able to diagnose a fault?

Share this post


Link to post
Share on other sites
 

Yes a garage should be able to diagnose the fault, if the engine management light was on the a fault code would have been stored. However after a while the code will be erased, if the fault has not reoccurred.

Share this post


Link to post
Share on other sites

the loss of power is normal when the e.m.l is on its called limp home mode,it could be a one off but as mentioned i would get the codes read to be sure.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now