Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Krose

Sounds Like I Have Tubo When Pressing Accelerator

1 post in this topic

Fusion 1.6 petrol 2003,

This is weird, might be linked but the car just doesn't sound right, it drives ok but occasionally its like getting hit by a gust of wind and a slight dip in power but only for a split second and the engine while moving just sounds rough but my main query is why when i touch the accelerator do i get a "cha" sound before it kicks in, when changing gear it sounds like i got a turbo. What can this be? is it a sign of something bad?

Am not overly concerned cause it still gets me from a-b but surely this is a problem and not a feature

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now