• Get Your Club gear
      Get Your Club gear
    • Share Your Car Experience
      Share Your Car Experience
    • Join Premium & Save
      Join Premium & Save
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Sign in to follow this  
Followers 0
Dan Swift

Ford focus 1.8 TDCI Y Reg

2 posts in this topic

Hi There

I was hoping someone could help me. I have a Focus 1.8 TDCI (2001) I recently went out in it and while on the Motorway the battery light came on, Then i noticed the lights dimming and the windscreen wipers slowing down. Then the power steering went completly. I pulled over. I then noticed that the front windscreen heater button wouldnt switch on and then, when turning the heater on from 1-4 that the power of the heater wasnt that fast. also there is no heat coming out of it, just cold air now.

I can turn the engine on and off without any problems. But i still have the above problems.

So basically:

Battery light stays on

No power steering

Front heater switch wont turn on

Wipers, lights and heater power are low

Heater only blowing cold air out

Does anybody know what this might be?

Any advice would be much appriciated

Thanks

Kind Regards

Dan

Share this post


Link to post
Share on other sites
 

Hi There

I was hoping someone could help me. I have a Focus 1.8 TDCI (2001) I recently went out in it and while on the Motorway the battery light came on, Then i noticed the lights dimming and the windscreen wipers slowing down. Then the power steering went completly. I pulled over. I then noticed that the front windscreen heater button wouldnt switch on and then, when turning the heater on from 1-4 that the power of the heater wasnt that fast. also there is no heat coming out of it, just cold air now.

I can turn the engine on and off without any problems. But i still have the above problems.

So basically:

Battery light stays on

No power steering

Front heater switch wont turn on

Wipers, lights and heater power are low

Heater only blowing cold air out

Does anybody know what this might be?

Any advice would be much appriciated

Thanks

Kind Regards

Dan

ALTERNATOR BELT! definetly. have a look under the bonnet on the left hand side as you look at the engine, i bet there is pulleys without a belt on them!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0