• 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Share Your Car Experience
      Share Your Car Experience
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Join Premium & Save
      Join Premium & Save
    • Get Your Club gear
      Get Your Club gear

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Intermittent Starting Problem With 06 (New Shape) 2.0Tdci Galaxy

2 posts in this topic


We purchased a used Galaxy a couple of months ago now. After the first few days it wouldn't start first time, the engine would turn over, but wouldn't fire. There was no pattern to it, it could be from cold, when it had been used, while on a flat surface, on a hill. Once it did start (which could take 2 goes and at max 5 goes) it was fine. No cutting out, smooth running. Took it back to the dealer we got it from, there were no fault codes and they have replaced the Fuel Filter and fuel filter housing, but it cut out on them the day it was meant to come back to us. They have now changed the crank shaft sensor and are unsure still if this has fixed the problem, but we are having the car back to at least try it and see if it happens again.

Anyway, has anyone had this problem or know what it might be. Feels like it is going to happen again, but just a case of when really!

Thanks :)

Share this post

Link to post
Share on other sites

Did the problem ever come back after you had the last fix?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now